Closed Bug 881424 Opened 7 years ago Closed 7 years ago

SimplePush: Enable push by default on b2g

Categories

(Firefox OS Graveyard :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:leo+, firefox22 wontfix, firefox23 wontfix, firefox24 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE3 (26jun)
blocking-b2g leo+
Tracking Status
firefox22 --- wontfix
firefox23 --- wontfix
firefox24 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: nsm, Assigned: nsm)

References

Details

(Whiteboard: [fixed-in-birch])

Attachments

(1 file, 1 obsolete file)

Comment on attachment 763831 [details] [diff] [review]
Set the SimplePush serverURL

Current push server uses wss://push.services.mozilla.com/

I can handle both URLs if that makes things easier.
Attachment #763831 - Flags: review?(jrconlin) → review-
Drop the /ws
Attachment #763831 - Attachment is obsolete: true
Attachment #763857 - Flags: review?(jrconlin)
Comment on attachment 763857 [details] [diff] [review]
Set the SimplePush serverURL

Review of attachment 763857 [details] [diff] [review]:
-----------------------------------------------------------------

Would prefer if there was a "/" at the end of the URL, however will + for the time being since the server accepts it.
Attachment #763857 - Flags: review?(jrconlin) → review+
https://hg.mozilla.org/mozilla-central/rev/20acf89efc15
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 763857 [details] [diff] [review]
Set the SimplePush serverURL

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Attachment #763857 - Flags: approval-mozilla-b2g18?
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 822712
User impact if declined: Push isn't available despite code being present
Testing completed: A few months of testing from both Moz and Tef.
Risk to taking this patch (and alternatives if risky): 
Low risk. This simply enables push and sets a default URL. Until app developers use it, it won't affect network or battery.
String or UUID changes made by this patch:
Does a pref change count as a string change?
Comment on attachment 763857 [details] [diff] [review]
Set the SimplePush serverURL

push needs to be enabled on b2g 1.1 by default.
Attachment #763857 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
(In reply to Doug Turner (:dougt) from comment #10)
> Comment on attachment 763857 [details] [diff] [review]
> Set the SimplePush serverURL
> 
> push needs to be enabled on b2g 1.1 by default.

Not to be a process nut, but we aren't accepting approvals anymore for 1.1, as we're past June 10th. This needs a leo+ to land.
This is a product requirement on our part (having push as part of the builds), so nominating it.
blocking-b2g: --- → leo?
I've pinged doug about this. It should not have gotten approval without QA testing and driver buy-in to enable the feature in 1.1. Backout may be incoming.
(In reply to Alex Keybl [:akeybl] from comment #15)
> I've pinged doug about this. It should not have gotten approval without QA
> testing and driver buy-in to enable the feature in 1.1. Backout may be
> incoming.

We discussed - push is a commitment even though it was disabled, people testing were enabling this pref on their own in 1.1 builds, and we've had good testing coverage from partners and services QA.
blocking-b2g: leo? → leo+
This seems to have landed on v1.1 hd but not v1.1?
Flags: needinfo?(ryanvm)
Comment 13 would suggest otherwise...
Flags: needinfo?(ryanvm)
You need to log in before you can comment on or make changes to this bug.