Closed Bug 881989 Opened 7 years ago Closed 3 years ago

Dragging & moving emails in gmail via mouse/trackpad will start selecting everything at the top or bottom

Categories

(Firefox for Metro Graveyard :: Browser, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1241856

People

(Reporter: kjozwiak, Unassigned)

References

Details

(Whiteboard: [defect] p=0)

When you attempt to move an email in Gmail, you will notice that when you move the email up or down, it will start highlighting everything. It will behave similarly to highlighting text and then scrolling through it to select a large portion of text.

- Reproduced the issue on two different machines (desktop machine & touch screen thinkpad)

Steps to reproduce the issue:

1) Open Firefox Metro
2) Login into gmail.com
3) Once logged in, select any email and start moving it up or down. You will notice that while dragging the email, you will start selecting everything else.

Current Behavior:

- Moving emails in Gmail will start selecting everything from the top or bottom depending on what direction you move the email.

Expected Behavior:

- When users move an email in Gmail, Firefox Metro shouldn't be selecting anything else.
Priority: -- → P1
Blocks: 887442
Whiteboard: feature=defect u=metro_firefox_user c=content_features p=0 → feature=defect c=browsing u=metro_firefox_user p=0
Whiteboard: feature=defect c=browsing u=metro_firefox_user p=0 → feature=defect c=browsing u=metro_firefox_user p=0 [preview-triage]
Whiteboard: feature=defect c=browsing u=metro_firefox_user p=0 [preview-triage] → [preview-triage] feature=defect c=browsing u=metro_firefox_user p=0
Blocks: metrov1backlog
No longer blocks: metrov1defect&change
I can't seem to move an email at all. I can open an email though by taping on it.
Assignee: nobody → msamuel
Blocks: metrov1it13
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
QA Contact: jbecerra
Summary: Defect - Dragging & moving emails in gmail will start selecting everything at the top or bottom → [MP] Defect - Dragging & moving emails in gmail will start selecting everything at the top or bottom
Whiteboard: [preview-triage] feature=defect c=browsing u=metro_firefox_user p=0 → [preview] feature=defect c=browsing u=metro_firefox_user p=0
Whiteboard: [preview] feature=defect c=browsing u=metro_firefox_user p=0 → [preview] feature=defect c=browsing u=metro_firefox_user p=5
Jim, I tried it on two machines and I can move them but the problem is still happening. I selected the emails and moved them via my mouse and the track pad, but there's no way of moving the emails via touch. Should we create a new bug for that? If someone uses a tablet they won't be able to move any emails via the drag method.
(In reply to Kamil Jozwiak [:kjozwiak] from comment #3)
> Jim, I tried it on two machines and I can move them but the problem is still
> happening. I selected the emails and moved them via my mouse and the track
> pad, but there's no way of moving the emails via touch. Should we create a
> new bug for that? If someone uses a tablet they won't be able to move any
> emails via the drag method.

Can we clarify the bug title here a bit and post current STR?

Sounds like google needs to do some work on gmail to be compat with our touch input support.
I've explored this a bit. It seems that using a mouse to move an email to a different folder will actually move the email but it will highlight any other text along the way.

I was unable, however, to move the email at all by dragging with my finger.
Depends on: 906034
Jim/Marina,

I split this into two different issues.

Issue #1: (This ticket): When dragging emails via a mouse or track pad in Gmail, you will be able to move the emails but it will select everything a long the way. You can still use the same steps in comment #0 to reproduce. Looks like Marina reproduced the issue as per comment #5

Issue #2: (Bug 906034): You cannot move emails in Gmail via touch making it impossible to clean up the inbox etc..
Summary: [MP] Defect - Dragging & moving emails in gmail will start selecting everything at the top or bottom → [MP] Defect - Dragging & moving emails in gmail via mouse/trackpad will start selecting everything at the top or bottom
Blocks: metrov1it14
No longer blocks: metrov1it13
Assignee: msamuel → nobody
Blocks: metrov1backlog
No longer blocks: metrov1it14
Status: ASSIGNED → NEW
QA Contact: jbecerra
No longer blocks: MetroPreviewRelease
Summary: [MP] Defect - Dragging & moving emails in gmail via mouse/trackpad will start selecting everything at the top or bottom → Defect - Dragging & moving emails in gmail via mouse/trackpad will start selecting everything at the top or bottom
Whiteboard: [preview] feature=defect c=browsing u=metro_firefox_user p=5 → feature=defect c=browsing u=metro_firefox_user p=5
Whiteboard: feature=defect c=browsing u=metro_firefox_user p=5 → [release28] feature=defect c=browsing u=metro_firefox_user p=5
Hey Kamil, can you investigate if this is only related to Gmail.
Flags: needinfo?(kamiljoz)
Checking that drag and drop in general works might be a good idea. This page has some examples:
  http://www.html5rocks.com/en/tutorials/dnd/basics/
Went through the issue again and ran into the same problem while using Outlook (hotmail). If you start dragging an email without physically selecting it via the check box, moving the email will auto-select it and then will start selecting everything when dragging it around the screen (same behaviour as mentioned in comment #0)

I went through some of the examples in the link that Tim attached in comment #8 and ran into issues when dragging. Clicked on a box that I wanted to move (it was highlighted), but couldn't drag it anywhere. When doing the same thing using the Nightly Desktop browser, everything worked without issues.

Was using the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-10-28-03-02-05-mozilla-central/
Flags: needinfo?(kamiljoz)
No longer depends on: 906034
OK so it sounds like our support for html5 drag an drop is broken. Filed bug 932520 for that issue and set it as blocking this one. Hopefully this bug and bug 906034 will just disappear once we fix drag and drop, but I'm leaving these two open in case there is more to be done.
Tested with m-c now that bug 932520 has landed; this seems to still be an issue
Blocks: metrobacklog
No longer blocks: metrov1backlog
Whiteboard: [release28] feature=defect c=browsing u=metro_firefox_user p=5 → feature=defect c=browsing u=metro_firefox_user p=5
Summary: Defect - Dragging & moving emails in gmail via mouse/trackpad will start selecting everything at the top or bottom → Dragging & moving emails in gmail via mouse/trackpad will start selecting everything at the top or bottom
Whiteboard: feature=defect c=browsing u=metro_firefox_user p=5 → [defect] p=0
No longer blocks: 947492
OS: Windows 8 Metro → Windows 8.1
Priority: P1 → --
Kamil, is this Metro-specific or is it a problem in regular Firefox too?
Flags: needinfo?(kjozwiak)
I can still reproduce this on all three platforms with the latest builds of fx. Whenever you select an email and start dragging it, you'll start selecting all the text underneath the email you've just selected. This doesn't happen when you grab the email via the "selector" to the left of the checkbox. However, if you grab the email from anywhere else and start dragging it, you'll reproduce the problem.

Quick example of the issue: https://youtu.be/vSZJBLublAI

Closing this as a duplicate of bug#1241856.

Builds:

* fx54.0, buildid: 20170608105825, changeset: e832ed037a3c - reproduced
* fx55.0b3, buildid: 20170619071954, changeset: be4a0ad5d6ca - reproduced
* fx56.0a1, buildid: 20170620030208, changeset: 7a6baa6cca32 - reproduced

Platforms:

* macOS 10.12.5 x64 - reproduced
* Ubuntu 16.04.2 LTS x64 VM - reproduced
* Win 10 x64 VM - reproduced
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(kjozwiak)
Resolution: --- → DUPLICATE
Duplicate of bug: 1241856
You need to log in before you can comment on or make changes to this bug.