PVT build for inari (1.1) break all cell connectivity

RESOLVED DUPLICATE of bug 876772

Status

RESOLVED DUPLICATE of bug 876772
5 years ago
5 years ago

People

(Reporter: hub, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
I installed the pvt build from June 12 of FxOS 1.1 on my Inari device.

While I had issues with 1.0.1 it somewhat found the network and had an IMEI number - and could get stuff going.

With 1.1 I have no IMEI number and SIM is in unknown state: ie NOTHING work.

I looks a bit like bug 876772
As far as I understand we need to be on Strawberry and not Chocolate for the RIL to work.

Comment 2

5 years ago
Hi :hub:

If device goes back as normal after below step, this issue is a duplicated of bug 876772.
Could you give a try? Thanks

---------------------------------
Please download rild/libril.so from below link:
http://people.mozilla.com/~echen/share/rild
http://people.mozilla.com/~echen/share/libril.so

Then push them into your device by below command:
adb remount
adb push rild /system/bin
adb push libril.so /system/lib
adb shell chmod 744 /system/bin/rild
adb reboot
Flags: needinfo?(hub)
(In reply to Edgar Chen [:edgar][:echen] from comment #2)
> If device goes back as normal after below step, this issue is a duplicated
> of bug 876772.

Thanks, this allows my device to connect to the cellular network.  The signal strength is _very_ weak when compared with an Android phone on the same network and the phones are sitting beside each other.

Comment 4

5 years ago
bug 876772 is landed, and I have tested the latest nightly build, device can connect to cellular network. So I mark this bug as a duplicated of bug 876772. Please feel free to re-open it if you still meet this issue. Thanks
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(hub)
Resolution: --- → DUPLICATE
Duplicate of bug: 876772
(Reporter)

Comment 5

5 years ago
I installed build 20130620230208 from "PVT" and it now "works" (ie it resolve that one specific issue).
You need to log in before you can comment on or make changes to this bug.