New helper type window reports wrong MIME type

VERIFIED DUPLICATE of bug 78943

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 78943
17 years ago
14 years ago

People

(Reporter: Spiros Ioannou, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Hello,
I've set up a server for mp3 songs many years ago which works fine with
netscape+other browsers. I tested it with the latest mozilla nightly build and
observed the following problem
To play the song.mp3 streaming, you click a link which results in the following
answer from the server (I got that by telneting to port 80):
----------------------------------------------------------
Connected to xxxxxxxxx
Escape character is '^]'.
GET /cgi-bin/mp3.m3u?mp3file=1&path=/dwse_oti_exeis/mysong.mp3 HTTP/1.0

HTTP/1.1 200 OK
Date: Thu, 28 Jun 2001 16:44:39 GMT
Server: Apache/1.3.19 (Unix) Debian/GNU PHP/4.0.5
Connection: close
Content-Type: audio/mpeg-url

http:///cgi-bin/mp3.m3u?mp3data=1&path=/dwse_oti_exeis/mysong.mp3
Connection closed by foreign host.
----------------------------------------------------------

As you can see Content-Type is audio/mpeg-url. The client (winamp)should then
download the actual song from the above reported link which then has the actual
data, and content type of audio/mpeg.

The problem is that as you can see the server reports Content-type:
audio/mpeg-url but when you click the link with mozilla, a window comes up which
sais: 
You have chosen to download a file of type: "Winamp playlist file"
[audio/x-mpegurl] from http://xxxxx etc. What should mozilla do with this file?

I choose always open it with e.g. winamp, but the problem is that the MIME type
of the file wasn't audio/x-mpegurl but audio/mpeg-url. So it keeps asking me
every time. It seems that it reads correctly the MIME type, but then tries to
set up a helper for *another* MIME type. The only way to install the helper is
to edit the MIME type in the preferences, and change it to the correct one. I
don't know where it got the audio/x-mpegurl maybe from its extension?

Comment 1

17 years ago
I can't even begin to guess where this belongs, but it's not a preferences bug.

->asa
Assignee: bnesse → asa
Component: Preferences: Backend → Browser-General
QA Contact: sairuh → doronr
It _did_ get the type from extension.  Marking duplicate of "MIME type reported
incorrectly for certain file extensions"

*** This bug has been marked as a duplicate of 78943 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED

Updated

17 years ago
Component: Browser-General → XP Apps
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.