If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Trash sorting reverts to default after Empty Trash

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Dimitrios, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build 2001062804, Win98.
After the recent checkin for automatic folder compacting, there are serious
repaint and sorting problems.
Reproducible: Always
Steps to reproduce:
1. Delete some messages in a specific folder. Keep focus on that folder, besure
sorting is set to date with newest messages on top (opposite of the installation
default)
2. Empty Trash

Actual Results:
a. After folder compacting  is executed, folder that had (marked as) deleted
items is painted blank. You need to switch to another folder and return, in
order to repaint it.
b. Sorting order returns to default (older messages on top).

Expected results:
Folder is painted correctly, messages keep being sorted with newer messages on
top of the old ones

Note: tested on folders of a POP3 account

Comment 1

16 years ago
Reporter try creating a new profile? Does that fix the problem?
(Reporter)

Comment 2

16 years ago
Tested with 2001071004 on Win95 and Win98 (old and new profiles exhibit the same
behaviour):
No problems at all in Inbox. There is only one issue: Trash folder sorting
returns to installation default (by date, oldest first) after the operation. The
same happens when using  the "compact folders" command. Is it a dupe of a known
folder compacting issue?
Otherwise, we could keep this bug open and change the summary to e.g. "Trash
sorting reverts to default order after compacting folders".
(Reporter)

Comment 3

16 years ago
Changing the summary (hoping this isn't inappropriate) since this is what
remained from the initially reported issues. It is easy to reproduce:
1. Go to Trash folder and select scending sorting by date so that arrow points
upwards, i.e newest messages are on top of the old ones.
2. Delete some messages. then execute "Empty Trash" or "Compact folders".

Then you see Trash folder sorting is so that older messages are in top of the
newest ones (arrow indicator points downwards).

build 2001072503, Win95/98
Summary: "Empty Trash" problems → Trash sorting reverts to default after compacting folders
(Reporter)

Comment 4

16 years ago
This bug can be easily confirmed, yet more than one month has passed. Why
doesn't anyone give a try ? Just follow the directions in my last comment.
compacting -> naving
Assignee: sspitzer → naving
(Assignee)

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 92056 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

16 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 7

16 years ago
Using the latest build (2001080303), compact command doesnt affect Trash folder
sorting anymore. But Empty Trash still reverts it. So originally there were two
bugs, only one of them is fixed. Reopening and changing summary (one more time).
(Assignee)

Updated

16 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Trash sorting reverts to default after compacting folders → Trash sorting reverts to default after Empty Trash
(Assignee)

Comment 8

16 years ago
Created attachment 46572 [details] [diff] [review]
proposed fix
(Assignee)

Comment 9

16 years ago
Transfer the sort info etc using transferInfo. cc bienvenu and seth 
for review. 

Comment 10

16 years ago
looks good in general, but why did you remove the call to -                    
 newTrashFolder->UpdateFolder(msgWindow);

Is that not needed somehow?
(Assignee)

Comment 11

16 years ago
ya, it was there to update the counts. GetMsgDatabase will do that and also
give us the db. seth, I need sr. 
sr=sspitzer
(Assignee)

Comment 13

16 years ago
fix checked in. 
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Updated

16 years ago
QA Contact: esther → laurel

Comment 14

16 years ago
Using oct2 0.9.4 commercial branch build: win98, mac OS X, linux rh6.2:
This works OK for POP3 folders.
Sort still changes for IMAP Trash folder using Empty Trash.

Do you want to reopen for IMAP case or have me log another bug?  Let me know...
(Assignee)

Comment 15

16 years ago
I thought this was just pop3 specific. ya, please log a new bug for imap. 

Comment 16

16 years ago
Logged a new report for IMAP issue... bug 102735.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.