[Audio] AMR_WB Audio in 3gp container is not playing

VERIFIED FIXED in 1.1 QE4 (15jul)

Status

P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: mbarone976, Assigned: dkuo)

Tracking

({regression})

unspecified
1.1 QE4 (15jul)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
STR

1. Open Music app and load an AMR_WB audio format in 3gp container

ACTUAL RESULT
The media file is not played

EXPECTED RESULT
The media file should be played
I don't believe we support playing of AMR media types off of the open web right now. We only plan to support it for the MMS-specific use cases. I believe that's intended behavior.

Roc - Can you confirm?
Flags: needinfo?(roc)
Component: Gaia → Video/Audio
Product: Boot2Gecko → Core
Version: unspecified → Trunk
(In reply to Jason Smith [:jsmith] from comment #1)
> I don't believe we support playing of AMR media types off of the open web
> right now. We only plan to support it for the MMS-specific use cases. I
> believe that's intended behavior.

That's definitely what I want!
Flags: needinfo?(roc)
Closing as invalid as this is expected, as we don't intend to support AMR media types. If you concerns about this, feel free follow with Sandip.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Hi all,

As I know that V1.1 just restricted the web content or apps who's permission is under APP_STATUS_PRIVILEGED. But pre-installed music app would be APP_STATUS_CERTIFIED so music app should be allowed to play 3gp or amr.
(In reply to Marco Chen [:mchen] from comment #4)
> Hi all,
> 
> As I know that V1.1 just restricted the web content or apps who's permission
> is under APP_STATUS_PRIVILEGED. But pre-installed music app would be
> APP_STATUS_CERTIFIED so music app should be allowed to play 3gp or amr.

I'm not sure we should allow playing of media content with an AMR media type, even in the music app.
(In reply to Jason Smith [:jsmith] from comment #5)
> I'm not sure we should allow playing of media content with an AMR media
> type, even in the music app.

The current Gecko's implementation on V1.1 allowed music app to play amr in 3gp container so I think the bug here is really an issue. If you still have a concern on supporting amr in 3gp maybe you can fire another bug to disable it.
(In reply to Marco Chen [:mchen] from comment #6)
> (In reply to Jason Smith [:jsmith] from comment #5)
> > I'm not sure we should allow playing of media content with an AMR media
> > type, even in the music app.
> 
> The current Gecko's implementation on V1.1 allowed music app to play amr in
> 3gp container so I think the bug here is really an issue. If you still have
> a concern on supporting amr in 3gp maybe you can fire another bug to disable
> it.

I think this is only valid bug if there's agreement between multiple groups that we should support that use case. To my understanding, I believe we do not want to support the use case you are describing.

I'm putting needinfo on Sandip to figure out what to do here.
Flags: needinfo?(skamat)
Note - I should mention that this bug was filed as a general issue with AMR media types, not specific to the music app. I'm following up over email what we want to do with the Music app.
Sandip over email mentions that we should only be supporting open codecs in our platform. He'll add more detail here later.

If AMR media types isn't disabled in the music app, then that's a bug which should be fixed.
Flags: needinfo?(skamat)
(In reply to Jason Smith [:jsmith] from comment #9)
> Sandip over email mentions that we should only be supporting open codecs in
> our platform. He'll add more detail here later.
> 
> If AMR media types isn't disabled in the music app, then that's a bug which
> should be fixed.

Actually, disregard this statement. I re-read the product spec on this.

AMR-NB & AMR-WB media type formats should be able to be played in the music app. They should not be able to be played on the web, however. So this actually is a valid bug then, but it's a music app specific issue.
Status: RESOLVED → REOPENED
Component: Video/Audio → Gaia::Music
Product: Core → Boot2Gecko
Resolution: INVALID → ---
Version: Trunk → unspecified
According to the product spec, this was supposed to be supported in 1.01. I'm guessing this is a regression then.
blocking-b2g: --- → leo?
Keywords: regression
Per comment 6, comment 11 marking leo+.

Marco, can someone look at this from Taipei?
Flags: needinfo?(mchen)
blocking-b2g: leo? → leo+
(Assignee)

Comment 13

6 years ago
Wayne, this issue is because the metadata parser of music app filter out some supported formats, AMR_WB audio in 3gp container is probably one of them, and bug 882099 will fix this.

mbarone, can you attach your test file? thanks.
Depends on: 882099
Flags: needinfo?(mbarone976)
Dominic already replied this so remove the needinfo.
Flags: needinfo?(mchen)
Assignee: nobody → squibblyflabbetydoo
(Reporter)

Comment 15

6 years ago
Created attachment 765236 [details]
File
Flags: needinfo?(mbarone976)
(Assignee)

Comment 16

6 years ago
Created attachment 765252 [details]
Hex dump of Content-01_AMR-WB_6.6kbps_Speech01.3gp

Thanks mbarone.

The major_brand is "3gp5" and compatible_brands is "isom" as gecko expected in bug 882099 comment 6.
Renom. We just minused bug 882669 and closed it as not valid for the other AMR type. Is this not valid as well?
blocking-b2g: leo+ → leo?
Flags: needinfo?(clee)
(In reply to Jason Smith [:jsmith] from comment #17)
> Renom. We just minused bug 882669 and closed it as not valid for the other
> AMR type. Is this not valid as well?

Meant to say bug 882689 there.

Updated

6 years ago
Duplicate of this bug: 882689
I've updated bug 882689 as a dup instead of invalid.

Per comment 10, this is a valid bug.  Changing status back to leo+.
blocking-b2g: leo? → leo+
Flags: needinfo?(clee)
(Assignee)

Updated

6 years ago
Assignee: squibblyflabbetydoo → dkuo
Depends on: 882683
Hardware: x86 → ARM
(Assignee)

Comment 21

6 years ago
Update: this issue will be also fixed by the patch of bug 882683.

Updated

6 years ago
Priority: -- → P1
Target Milestone: --- → 1.1 QE4 (15jul)
(Assignee)

Comment 22

6 years ago
Fixed by bug 882683.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
status-b2g18: --- → fixed
Resolution: --- → FIXED

Comment 23

6 years ago
It is possible to play the content: Content-01_AMR-WB_6.6kbps_Speech01 from music app. Also, it is possible to attach and send the content successfully in a MMS. 

Verified with unagi v1-train 07/15 build:
Gecko-2b310a1
Gaia-d52ce22
ref ril
Status: RESOLVED → VERIFIED

Updated

6 years ago
status-b2g18: fixed → verified
You need to log in before you can comment on or make changes to this bug.