Provide about:healthreport access to updater hook

RESOLVED FIXED in Firefox 23

Status

defect
P2
normal
RESOLVED FIXED
6 years ago
10 months ago

People

(Reporter: abc, Assigned: nalexander)

Tracking

unspecified
Firefox 24
All
Android

Firefox Tracking Flags

(firefox23+ fixed)

Details

Attachments

(1 attachment)

No description provided.
Blocks: 880534
Component: Web: Health Report → Client: Android
Summary: Trigger app updates from a tip within about:healthreport → Trigger app updates on Android from a tip within about:healthreport
Just like chrome/content/about.xhtml.
No longer blocks: 880534
OS: Mac OS X → Android
Priority: -- → P2
Hardware: x86 → All
Summary: Trigger app updates on Android from a tip within about:healthreport → Provide about:healthreport access to updater hook
MOZ_UPDATER is not defined on beta or release.

http://mxr.mozilla.org/mozilla-central/source/mobile/android/branding/official/configure.sh#7

See Bug 800397, Bug 766636.

So the UpdateHelperService does nada unless you're on Nightly or Aurora.

We should check for MOZ_UPDATER and open 

  https://play.google.com/store/apps/details?id=$ANDROID_PACKAGE_NAME

if it's not defined, or trigger the updater if it is. I'm happy to have a shoddy UI on Nightly/Aurora, because the updater should run automatically in these cases anyway.

If the Play URI doesn't open Play by default, then we should manually construct the intent.
Assignee: nobody → nalexander
Status: NEW → ASSIGNED
The code to launch the Play Store was stolen from
Feedback:OpenPlayStore; I have *not* device tested it.  I will do that
now.  (I have tested ignoring and opening about:.)

I provide a boolean return code that I'm not returning to the Jelly; I
don't care about the Jelly dealing with ignored update launches for
v1.
Attachment #766049 - Flags: review?(rnewman)
> The code to launch the Play Store was stolen from
> Feedback:OpenPlayStore; I have *not* device tested it.  I will do that
> now.  (I have tested ignoring and opening about:.)

Works on my Samsung Galaxy SII, Android 4.0.3 (with a testing patch).
Attachment #766049 - Flags: review?(rnewman) → review+
https://hg.mozilla.org/services/services-central/rev/0b51d02bebd0
Whiteboard: [fixed in services]
Target Milestone: --- → Firefox 24
Comment on attachment 766049 [details] [diff] [review]
Add LaunchUpdater message to Android about:healthreport wrapper. r=rnewman

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  New functionality to support initial set of FHR tips.

User impact if declined: 
  FHR will have very few actionable tips!

Testing completed (on m-c, etc.): 
  Just landed on s-c; Nick has tested manually.

Risk to taking this patch (and alternatives if risky): 
  Essentially zero; it's purely additive.
String or IDL/UUID changes made by this patch:
Attachment #766049 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/0b51d02bebd0
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in services]
Comment on attachment 766049 [details] [diff] [review]
Add LaunchUpdater message to Android about:healthreport wrapper. r=rnewman

[Triage Comment]
Switching the aurora nom to beta and approving as this is needed for Fx23 beta 1 and confirmed its low risk.
Attachment #766049 - Flags: approval-mozilla-aurora? → approval-mozilla-beta+
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.