Closed Bug 88293 Opened 18 years ago Closed 18 years ago

file:// URLs w/ UNCs do not work

Categories

(Core :: Networking: File, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED WONTFIX

People

(Reporter: smoehle, Assigned: dougt)

References

Details

Mozilla will not load a file:// URL that has a UNC path. The URL can be a link
on a web page or type in to the Location (URL) bar.  Mozilla silently fails.  No
error messages are displayed nor is there any errors in the JavaScript console
nor is anything written to stderr. An example of a URL that will not work is
file:////mymachine/public/index.html. Such UNC file URLs work fine with both NN4
and IE5, and I am almost absolutely positive that this worked with earlier
versions of Mozilla as well.

To reproduce:
1) Type a valid file:// URL with a UNC path in the Location bar.
2) Press return.  Nothing happens.

Tested with Mozilla trunk build 2001062804 on Win2000.
Try file://///mymachine/public/index.html
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
This would be nice for 4xp/compatibility sake.
REOPEN: this sounds like a real problem to me.
Status: RESOLVED → UNCONFIRMED
QA Contact: tever → benc
Resolution: INVALID → ---
Summary: Cannot load file:// URLs that have UNC paths → file:// URLs w/ UNCs do not work
This looks like its covered by bug 101953

You can reopen if you disagree

*** This bug has been marked as a duplicate of 101953 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
Nope. need this to stay separate. The idea is to have all broken feature point
to the bug via a "depends on", so that we can check out each problem one by one.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
confirming...
Status: UNCONFIRMED → NEW
Ever confirmed: true
windows 2k.  what system are you using?
Status: NEW → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → WORKSFORME
Doug T:

win2k build 20011008.. (10min old CVS)

NS4.78:
file://laptopw2k/c/test.txt                            works
file://///laptopw2k/c/test.txt will be converted to :
file:////laptopw2k/c/test.txt                          and works 

Mozilla:
file://laptopw2k/c/test.txt                             doesn't work
file:////laptopw2k/c/test.txt                           doesn't work
file://///laptopw2k/c/test.txt                          works

This can't be worksforme. 
This is invalid/wontfix or a dupe or a real bug.



Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Hi Matti:

Mozilla:
file://laptopw2k/c/test.txt                             doesn't work
file:////laptopw2k/c/test.txt                           doesn't work

the above two are invalid URI's.  The 4.x handling behavior, if applied to
mozilla has extraordinary performance problems.

so, I guess, I should just mark this as wontfix?

thanks.
Status: REOPENED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → WONTFIX
Dougt: 
Sorry for that SPAM but I want only be sure that this bug is wontfix.
(and the reporter should know why this bug is wontfix...)

Thanks !

verified wontfix (Benc: please don't kill me for that  :-)




Status: RESOLVED → VERIFIED
No longer depends on: 101953
*** Bug 289302 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 571846
Duplicate of this bug: 1058527
You need to log in before you can comment on or make changes to this bug.