Closed Bug 882937 Opened 7 years ago Closed 7 years ago

GTest dependency don't support adding/removing files

Categories

(Firefox Build System :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla24

People

(Reporter: BenWa, Assigned: BenWa)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

I noticed when adding more tests to GTest that adding/removing files doesn't trigger a rebuild. This is a regression from bug 844288.

The build system considers gfx/test/gtest to be a component linked in libxul but the dependency don't pick up that a new file should be added to the list.

How do we support this?
Can you be more specific about what's not rebuilding? The libxul-test library isn't being relinked?
Yes. The new object file is build but since it's not in toolkit/library/.deps/gtest/XUL (mac path) it doesn't get relinked. How does regular libxul detect that new files were added and that it needs to relink?
(In reply to Benoit Girard (:BenWa) from comment #2)
> How does regular libxul detect that new files were added and that it needs to relink?

By having dependencies on .desc files, one of which should have been updated to contain the new file.
Attached patch Fix Deps (obsolete) — Splinter Review
Looks like I messed up the dependency when applying the review comment.

DLL_SUFFIX includes the '.' and it's not redefined when generating a framework.
Assignee: nobody → bgirard
Status: NEW → ASSIGNED
Attachment #762649 - Flags: review?(mh+mozilla)
Attached patch Fix Deps (obsolete) — Splinter Review
Removed debugging echo
Attachment #762649 - Attachment is obsolete: true
Attachment #762649 - Flags: review?(mh+mozilla)
Attachment #762650 - Flags: review?(mh+mozilla)
Attached patch Fix DepsSplinter Review
Attachment #762650 - Attachment is obsolete: true
Attachment #762650 - Flags: review?(mh+mozilla)
Attachment #762680 - Flags: review?(mh+mozilla)
Attachment #762680 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/62f26a2bab83
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.