Closed Bug 882959 Opened 8 years ago Closed 8 years ago

Initialize app.geo.reportdata pref to avoid annoying nsIPrefBranch.getCharPref() exceptions

Categories

(Firefox for Android :: General, defect)

23 Branch
All
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 24
Tracking Status
firefox23 --- unaffected
firefox24 --- fixed

People

(Reporter: cpeterson, Assigned: cpeterson)

References

Details

(Keywords: regression)

Attachments

(1 file)

Every time I run Fennec, the following JS exception is dumped to logcat because Fennec is trying to read the uninitialized "app.geo.reportdata" pref:

E/GeckoConsole( 8712): Error reading pref [app.geo.reportdata]: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://browser/content/browser.js :: getPreferences :: line 1044"  data: no]

This warning is harmless, but it is very annoying because I do a double-take every time I see "Error" and "Exception" in logcat when debugging. :)
Attachment #762370 - Flags: review?(blassey.bugs)
Attachment #762370 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/7fc2d9ea82b6
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
You need to log in before you can comment on or make changes to this bug.