If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

the frame size of Video element is not properly set.

RESOLVED FIXED in Firefox 25

Status

Firefox OS
General
P1
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Leo, Assigned: kanru)

Tracking

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, firefox22 wontfix, firefox23 wontfix, firefox24 wontfix, firefox25 fixed, firefox-esr17 wontfix, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd affected)

Details

(Whiteboard: [TD-43789])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
1. Title:[Browser] Video frame size is not properly set.
2. Precondition: Browser is working. 
3. Tester's Action:  (1) Open a website containing direct linked video
                     (2) Click on a video link to start playing
                     (3) Observe that video will be start playing in embedded player 
4. Detailed Symptom (ENG.) : Video frame size is not adjusted to the screen size.
5. Expected: Video frame size is properly adjusted to the screen size.
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train: Reproduced on v1-train and master 
8. Gaia Revision:  bd07ce233160a0e6325bf736769772a9d2273458
(Reporter)

Updated

4 years ago
blocking-b2g: --- → leo+
Is it possible to give us the video and screenshot??
Created attachment 763901 [details]
imdb.com's main page
Created attachment 763903 [details]
not screen fit
add more information

STR>
browser -> 
http://m.imdb.com -> 
start playing one of trailers video on the top of this page.
in this case, video is "Elysium" (refer to imdb.com's main page of attachments)

video screen fits to horizontal screen. so, it is oversized on portraite mode.
Jeremy,

Thanks for your STR. It does what you say. This video is not handled by video app but video element of browser.

Updated

4 years ago
Component: Gaia::Browser → General
Summary: [Browser] Video frame size is not properly set. → the frame size of Video element is not properly set.
(Reporter)

Updated

4 years ago
Priority: -- → P1

Comment 6

4 years ago
Over to blassey for reassignment (hope that functional group -> mgr mapping is correct)
Assignee: nobody → blassey.bugs
Hi all, I'd like to suggest small thing to fix this bug.
Here are ..
 1. Adjust the controller size for video element to the size of viewport.
    Since we open a video element in browser, we can zoom in/out the content. 
    I think it's good UX and the performance is good enough. 
    But the problem here is the controller. 
    It must fit to the size of viewport but currently it fits the size of controller to  size of content. That's why user can not see the whole controller.
     
 2. Adjust the zoom rate for the video element when user open it first time.
    Currently, when we open the video in browser, the zoom rate is 1.0. It means the video element get the real size of the content and doesn't fit to the viewport.

Please, consider this. 
thank you.
Assignee: blassey.bugs → bfrancis
Taking a look at this, so the video player is a document loaded by 

http://mxr.mozilla.org/mozilla-central/source/content/html/document/src/VideoDocument.cpp

and uses https://github.com/mozilla/mozilla-central/blob/master/layout/style/TopLevelVideoDocument.css

This is the same code used for firefox desktop and firefox android, in both of which the content works fine (it also works as expected on b2g desktop). On the device however we have various rendering errors, the viewport is set incorrectly, on rotating the video the entire background turns white, the pan and zoom lets us move the content outside where it should be possible and the video width it set incorrectly.

Given that the code is fine and desktop, android and b2g desktop are working, there must be a layout issue, need infoing, Robert do you have any idea what could be causing this document to act so wrong on firefox os devices?
Assignee: bfrancis → dale
Flags: needinfo?(roc)
Try adding to http://mxr.mozilla.org/mozilla-central/source/content/html/document/src/VideoDocument.cpp creation of a <meta viewport> tag to disable scaling by the browser?
Flags: needinfo?(roc)
Er, disable scaling and panning/zooming.
Just an update while I am debugging

We set the meta viewport size correctly (although do not disable scaling etc) in 
http://mxr.mozilla.org/mozilla-central/source/content/html/document/src/MediaDocument.cpp#243

http://junk.arandomurl.com/testvideo.html has none of the same bugs that the VideoDocument generate page does, despite being an identical dom

Currently debugging whether the viewport info is correctly picked up
Even more confusingly, if I build B2G manually and flash, the page is white (but behaves correctly) but if I flash the latest nightly build then the page is grey, picking up the css from /toolkit/themes/osx/global/media/TopLevelVideoDocument.css and doesnt behave (size) correctly
Quick update, as far as I can tell we are including the windows theme css in http://mxr.mozilla.org/mozilla-central/source/content/html/document/src/VideoDocument.cpp#77 

but not able to load the global styles for this page in http://mxr.mozilla.org/mozilla-central/source/content/html/document/src/VideoDocument.cpp#76

which would cause this bug
Confirmed that the problem is the global style is failing to be linked, the call to LinkStyleSheet is successful (chrome linked css does work as well) and the css is packaged in dist/bin/res so not exactly sure what is failing
(Assignee)

Comment 15

4 years ago
dist/bin/res/TopLevel{Video,Image}Document.css are not included in the final omni.ja file. I'm looking for reasons.
(Assignee)

Comment 16

4 years ago
Created attachment 768231 [details] [diff] [review]
Patch for m-c
Assignee: dale → kchen
Status: NEW → ASSIGNED
(Assignee)

Comment 17

4 years ago
Created attachment 768232 [details] [diff] [review]
Patch for b2g18
kanru, are these patches ready for review?
Flags: needinfo?(kchen)
(Assignee)

Updated

4 years ago
Attachment #768231 - Flags: review?(roc)
(Assignee)

Updated

4 years ago
Flags: needinfo?(kchen)
Comment on attachment 768231 [details] [diff] [review]
Patch for m-c

Review of attachment 768231 [details] [diff] [review]:
-----------------------------------------------------------------

I think technically this is build-system code that requires a build-system peer to review. But patches to this file seem to get reviews from all over.
Attachment #768231 - Flags: review?(roc) → review+
(Assignee)

Comment 20

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/a039e9463abe
(Assignee)

Comment 21

4 years ago
https://hg.mozilla.org/releases/mozilla-b2g18/rev/d5039dfd3f2d
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
status-b2g-v1.1hd: --- → affected
status-firefox22: --- → wontfix
status-firefox23: --- → wontfix
status-firefox24: --- → wontfix
status-firefox25: --- → affected
status-firefox-esr17: --- → wontfix
https://hg.mozilla.org/mozilla-central/rev/a039e9463abe
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
status-firefox25: affected → fixed
You need to log in before you can comment on or make changes to this bug.