Closed Bug 883035 Opened 7 years ago Closed 7 years ago

[Email] Folder list card "last sync" label can overlap the settings icon; visible on pt-BR locale

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE3 (26jun)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed
b2g-v1.1hd --- fixed

People

(Reporter: leo.bugzilla.gaia, Assigned: asuth)

Details

(Whiteboard: [TD-44145])

Attachments

(2 files)

1. Title : Settings icon overlaps on to last sync value string in other languages
2. Precondition : Change the languages to other languages,  Email should be working and an IMAP account is configured
3. Tester's Action:  Launch Email -> click on Folder List Icon -> See the settings Icon and Last Sync value
4. Detailed Symptom (ENG.) : Settings Icon overlaps on to Last Sync value.
5. Expected :Settings Icon should not overlap on to Last Sync value
6.Reproducibility: Y
           1)Frequency Rate : 100%
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 517d3d9f0d7538095799c9c067e398fb8ba96ba2
9.Personal email id:  psingapati@gmail.com
blocking-b2g: --- → leo+
Image showing settings icon over lap in an other languages
I think these are the actions to take:
- Add an l10n note to "account-last-synced-label"; we won't change the english translation or the string id since we can otherwise deal with this problem.
- Explicitly try and establish sizing bounds on our "fld-nav-last-synced" div.
- Switch to using the "-short" l10n date time.

We are currently using the -long variant, for which pt-BR has:
  minutes-ago-long[other] = {{value}} minutos atrás
in contrast to:
  minutes-ago-short[other] = {{value}}min atrás

So that will save us some screen real-estate.
Status: NEW → ASSIGNED
QA Contact: bugmail
Summary: [Email] Settings icon overlaps on to last sync value string in other languages → [Email] Folder list card "last sync" label can overlap the settings icon; visible on pt-BR locale
Attachment #762940 - Flags: review?(psingapati)
All the code is looks fine.
But it is not working as expected in other languages.
In the b2g\gaia\shared\locales\date\date.pt-BR.properties

minutes-ago-short={[ plural(m) ]}
minutes-ago-short[zero] = just now
minutes-ago-short[other] = {{m}}m ago

is expecting the object with attribute 'm'
Where as we are passing 'value' to it from l10n_date.js#153.

So we need to change the properties files for -short date with the 'value' attribute.

Please check.

Thanks

PS: I am not able to set the r+, did not find an option with my id psingapati.
Flags: needinfo?(bugmail)
You would set the review flag to "+" in the "details" page of the patch.  I think you should be able to set it, but maybe you need an additional privilege?

It appears that the problem you cite was a "bug" in the pt-BR locale, fixed on May 7th, see:
https://hg.mozilla.org/gaia-l10n/pt-BR/rev/74b44cab3c03#l10.10

I don't understand how your v1.1 branch or partner builds work in relation to l10n, but you'll need that change somehow.
Flags: needinfo?(bugmail)
(In reply to Andrew Sutherland (:asuth) from comment #5)
> You would set the review flag to "+" in the "details" page of the patch.  I
> think you should be able to set it, but maybe you need an additional
> privilege?
> 
> It appears that the problem you cite was a "bug" in the pt-BR locale, fixed
> on May 7th, see:
> https://hg.mozilla.org/gaia-l10n/pt-BR/rev/74b44cab3c03#l10.10
> 
> I don't understand how your v1.1 branch or partner builds work in relation
> to l10n, but you'll need that change somehow.

Stas - can you help get this uplifted (if it hasn't already)?
Flags: needinfo?(stas)
Comment on attachment 762940 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10403#attch-to-bugzilla

Everything looks fine.
Verified the issue with the Pull Request, issue is working fine.

But in case of es , still the -short attributes are not updated.
https://hg.mozilla.org/gaia-l10n/es/file/0fc4d28a3269/shared/date/date.properties

Please check
Attachment #762940 - Flags: review?(psingapati) → review+
(In reply to psingapati from comment #7)
> But in case of es , still the -short attributes are not updated.
> https://hg.mozilla.org/gaia-l10n/es/file/0fc4d28a3269/shared/date/date.
> properties

This is fixed as of yesterday, it appears:
https://hg.mozilla.org/gaia-l10n/es/rev/e14a5248c598#l25.1

Still a little unclear on how that gets into v1-train usually, but I'm going to land the pull request now since that specific landing had the comment "First push from transifex for 1.1", so it sounds like that is definitely happening or has already happened.

landed in gaia/master:
https://github.com/mozilla-b2g/gaia/pull/10403
https://github.com/mozilla-b2g/gaia/commit/4df544b615e4c80f415bcb230d28f35e7f8151c7

:jrburke, just cc'ing you as a heads-up, even though your merge or rebase or whatever should show you what's up.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Uplifted 4df544b615e4c80f415bcb230d28f35e7f8151c7 to:
v1-train: e67f6fe1fd0b772aa041b500b232d703fb3606b4
(In reply to Alex Keybl [:akeybl] from comment #6)
> (In reply to Andrew Sutherland (:asuth) from comment #5)
> > You would set the review flag to "+" in the "details" page of the patch.  I
> > think you should be able to set it, but maybe you need an additional
> > privilege?
> > 
> > It appears that the problem you cite was a "bug" in the pt-BR locale, fixed
> > on May 7th, see:
> > https://hg.mozilla.org/gaia-l10n/pt-BR/rev/74b44cab3c03#l10.10
> > 
> > I don't understand how your v1.1 branch or partner builds work in relation
> > to l10n, but you'll need that change somehow.
> 
> Stas - can you help get this uplifted (if it hasn't already)?

Doing drops of l10n into gaia doesn't need us, best way to get some engineer to do it is to file a bug.
Flags: needinfo?(stas)
1.1hd: e67f6fe1fd0b772aa041b500b232d703fb3606b4
Assignee: nobody → bugmail
QA Contact: bugmail
You need to log in before you can comment on or make changes to this bug.