new tab does not preserve NoSquint setting

RESOLVED FIXED in Firefox 24

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: baron, Assigned: ttaubert)

Tracking

Trunk
Firefox 24
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Using the add-on NoSquint, when I open a new tab, then open a URL in that tab, the NoSquint setting is not preserved. This occurred around June 1 or shortly after. I am using nightly builds, and there was no new version of NoSquint, so this is likely the result of a change in how Firefox opens new tabs with nothing in them.

I do not get the problem if I right-click on a link and then select "open link a new tab". That works.

If I open a new tab first (from the File menu, or with ctrl-t) and then try to open a page in that tab, I do get the problem (as I said). And, when I first open the tab, the NoSquint setting in the add-on bar (like the status bar) at the bottom shows briefly as 100% and then turns into N/A. It is usually set on 150%. Thus, I think the problem is in whatever opens the new tab, not in the page loading.

If I open the url before the N/A appears, the new page opens correctly and the setting returns to 150%.

I have reported this to NoSquint, and a few others have confirmed that they have the same problem:
https://github.com/jtackaberry/nosquint/issues/91
(Reporter)

Comment 1

6 years ago
I just discovered a work-around:

In about:config, change
browser.newtab.url to blank, that is, click on that setting and hit the enter key. The "about:newtab" disappears. The images that used to appear in the new tab do not appear, but that is a small price to pay for getting NoSquint to work. (As Firefox users get older, NoSquint will be used more and more.)
This is caused by new tab page preloading.
Blocks: 791670
OS: Linux → All
Hardware: x86_64 → All
(Assignee)

Updated

6 years ago
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
NoSquint listens for TabOpen, like probably hundreds of add-ons. We should of course switch docShells before firing the TabOpen event - I should've thought of that.

This fixes the described issue for me and NoSquint works as expected.
Attachment #764788 - Flags: review?(dao)
Comment on attachment 764788 [details] [diff] [review]
fire TabOpen after swapping docShells for preloaded newtab pages

Sorry I got the patch description wrong. We of course need to fire TabOpen *after* docShells may have been swapped.
Attachment #764788 - Attachment description: fire TabOpen before swapping docShells for preloaded newtab pages → fire TabOpen after swapping docShells for preloaded newtab pages
Attachment #764788 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/aa8f4c550585
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
You need to log in before you can comment on or make changes to this bug.