Closed Bug 883145 Opened 6 years ago Closed 6 years ago

Window gradient misalignment in customize mode

Categories

(Firefox :: Toolbars and Customization, defect)

All
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: shorlander, Assigned: shorlander)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:M?][Australis:P-][good first verify])

Attachments

(3 files)

Attached image Unaligned Gradients
Going into customization mode is jarring partly because of perf and partly because the appearance shifts. Is it possible to use the actual window texture/gradient instead of switching to another CSS simulated gradient?
Whiteboard: [Australis:M?] → [Australis:M?][Australis:P5]
Whiteboard: [Australis:M?][Australis:P5] → [Australis:M?][Australis:P-]
Some notes, since I was editing this recently.

The files you'll want to change are probably
http://mxr.mozilla.org/mozilla-central/source/browser/themes/linux/browser.css#2007 and
http://mxr.mozilla.org/mozilla-central/source/browser/themes/osx/browser.css#4137
to make the customize-mode gradient more like the default gradient, I think…
(In reply to Blake Winton (:bwinton) from comment #1)
> Some notes, since I was editing this recently.
> 
> The files you'll want to change are probably
> http://mxr.mozilla.org/mozilla-central/source/browser/themes/linux/browser.
> css#2007 and
> http://mxr.mozilla.org/mozilla-central/source/browser/themes/osx/browser.
> css#4137
> to make the customize-mode gradient more like the default gradient, I think…

^5

Thanks!
Summary: Window gradient in normal state doesn't line up with window gradient in customize mode → Window gradient misalignment and 1px offset in customize mode
Summary: Window gradient misalignment and 1px offset in customize mode → Window gradient misalignment in customize mode
Comment on attachment 8382585 [details] [diff] [review]
fix-customization-mode-osx-gradient.patch

Review of attachment 8382585 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good, thanks!
Attachment #8382585 - Flags: review?(jaws) → review+
https://hg.mozilla.org/integration/fx-team/rev/f6a5f2514424
Keywords: checkin-needed
Whiteboard: [Australis:M?][Australis:P-] → [Australis:M?][Australis:P-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/f6a5f2514424
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M?][Australis:P-][fixed-in-fx-team] → [Australis:M?][Australis:P-]
Target Milestone: --- → Firefox 30
Comment on attachment 8382585 [details] [diff] [review]
fix-customization-mode-osx-gradient.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: titlebar gradients in customization mode and out look different
Testing completed (on m-c, etc.): on m-c, manual testing
Risk to taking this patch (and alternatives if risky): low - can't really get worse than it is now, and is a localized fix.
String or IDL/UUID changes made by this patch: none
Attachment #8382585 - Flags: approval-mozilla-aurora?
Attachment #8382585 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [Australis:M?][Australis:P-] → [Australis:M?][Australis:P-][good first verify]
You need to log in before you can comment on or make changes to this bug.