Closed Bug 883169 Opened 7 years ago Closed 6 years ago

Signature Summary doesn't contain B2G data

Categories

(Socorro :: Database, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kairo, Assigned: rhelmer)

References

Details

Both https://crash-stats-django.mozilla.org/report/list?signature=nsXPCWrappedJS%3A%3AAddRef%28%29 and https://crash-stats.mozilla.com/report/list?signature=nsXPCWrappedJS%3A%3AAddRef%28%29 don't show any B2G numbers in the Signature Summary, while the latter page shows a number of them in the Reports tab (the former doesn't which seems to be a different, socorro-crashstats-specific bug that I'll file as well).

I suspect that the DB's matview is not generating B2G data for signature summary.
Assignee: nobody → bsavage
Here's a current example (we fixed that other crash): https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Agl%3A%3ASharedSurface_Gralloc%3A%3A~SharedSurface_Gralloc
Assignee: bsavage → nobody
Depends on: 918068
After taking a look at the code and the data, it's pretty clear that the problem is that the matviews rely upon reports_clean for their data source, while reports_clean only receives reports from the reports table when they meet a certain criteria, which includes:

* A valid release channel
* A valid, known build id

Since our partners create builds themselves, we don't necessarily receive a build ID and thus don't know about the build. Also, the release channels they use don't follow standard nightly/aurora/beta/release channels, so the data ends up being excluded from signature summaries.
Talking with KaiRo in IRC, this bug is essentially WFM but we're going to leave it open until resolution of the larger issues is complete, so that we can test it after the fact.
Depends on: 928051
Assignee: nobody → rhelmer
Bug 928051 landed and resolved some other expected things, but did not resolve this one. Needs more investigation.
Status: NEW → ASSIGNED
(In reply to Robert Helmer [:rhelmer] from comment #4)
> Bug 928051 landed and resolved some other expected things, but did not
> resolve this one. Needs more investigation.

Actually I take that back - looks like this is working, KaiRo do you agree?

See https://crash-stats.mozilla.com/report/list?product=FennecAndroid&range_value=7&range_unit=days&date=2014-03-18&signature=FreeArenaList&version=FennecAndroid%3A27.0 for instance, B2G 18.0 (which is predominantly ZTE builds now) is showing up there.
Flags: needinfo?(kairo)
(In reply to Robert Helmer [:rhelmer] from comment #5)
> (In reply to Robert Helmer [:rhelmer] from comment #4)
> > Bug 928051 landed and resolved some other expected things, but did not
> > resolve this one. Needs more investigation.
> 
> Actually I take that back - looks like this is working, KaiRo do you agree?
> 
> See
> https://crash-stats.mozilla.com/report/
> list?product=FennecAndroid&range_value=7&range_unit=days&date=2014-03-
> 18&signature=FreeArenaList&version=FennecAndroid%3A27.0 for instance, B2G
> 18.0 (which is predominantly ZTE builds now) is showing up there.

That's a URL for an Android report but it looks like there's a B2G in the Products list, yes.

The signature summaries for the report/list examples in bug 860762 comment #9 look even better, and they also show the "ZTE roamer2" in the "Mobile Devices" section, which is what the ZTE Open with FxOS 1.0.1 is actually expected to be reporting, so I think we can call this one fixed by bug 928051 as well! \o/
Flags: needinfo?(kairo)
Resolved per comment 6, thanks!
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.