[req] ability to design skins in a display propeties fashion

RESOLVED WONTFIX

Status

()

Core
XUL
P5
enhancement
RESOLVED WONTFIX
19 years ago
10 years ago

People

(Reporter: Chris Booton, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({helpwanted})

Trunk
Future
x86
Windows 98
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I think it would be real groovy if you could via a menu command bring up a window simular to the win 95/98
appearence section of the control panel that could be used to design the skin colors etc. Possible it could have a sepearte tab for each part of communicator (ie messenger,browser address book) or if you wanted you could also have it so that you could pick a general color scheme for the entire suite. This would be easier then going to a site to do it, and anyone of any skill level could use it.

Updated

19 years ago
Assignee: don → trudelle
Component: Browser-General → XUL
QA Contact: leger → ckritzer

Comment 1

19 years ago
Setting componet and QA Contact

Updated

19 years ago
Assignee: trudelle → german

Comment 2

19 years ago
yeah, baby, yeah!!!
reassigning to german for consideration, cc'ing hyatt

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15

Comment 3

19 years ago
later.

Comment 4

19 years ago
spam: changing qa contact from ckritzer -> paulmac for xul bugs

Updated

18 years ago
Target Milestone: M15 → M16

Comment 5

18 years ago
Matt:
I am moving to m16, since we will not likely have skin switching capability by
m14, the currently prototyped dialog should suffice for beta and beyond to simply
assign skins to components. I cannot image that we have the resources to create a
skin editor the way you describe for 5.0, although it would be really nice.
Unless somebody on the net steps forward with some real, cold, hard code as well
as the respective XUL interface I just don't see it happen in time for the first
release. Any takers?

Comment 6

18 years ago
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL

Comment 7

18 years ago
*IGNORE* - more massive spam, changing open XPToolkit bug's QA contact to
jrgm@netscape.com

QA Contact: paulmac → jrgm

Comment 8

18 years ago
Adding 'skins' keyword to appropriate bugs en masse, sorry about any 
mistakes...
Keywords: skins

Updated

18 years ago
Blocks: 29160

Comment 9

18 years ago
Mass-adding beta2 keyword to all skins bugs.
Keywords: beta2

Comment 10

18 years ago
Removing the skins and beta 2 keyword and the dependency from bug 29160 on this 
bug, since this request for enhancement will not hold up skinnability at all. 
In fact we can do this after NS 6 ships. Right now we are only planning on 
showing a small author-generated bitmap preview for each skin in the appearance 
panel. Also moving to m20. We are accepting fixes/patches if anybody needs this 
kind of functionality, please talk to Ben Goodger (ben@netscape.com)
No longer blocks: 29160
Keywords: beta2, skins
Priority: P3 → P5
Target Milestone: M16 → M20

Comment 11

18 years ago
*** Bug 45620 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
a skin editor of the kind described is not something we can do in the timkeframe 
described. This is something a contributor or third party could easily take on. 
Marking future milestone, setting keyword helpwanted
Keywords: helpwanted
Target Milestone: M20 → Future

Comment 13

18 years ago
since this is something a mozilla contributor could engage on I propose
reassigning this bug to ben, the mozilla UI owner
Assignee: german → ben
Status: ASSIGNED → NEW
You can already change the colours of the classic skin by modifying your system 
settings. Discrepancies of the classic skin with your system settings should be 
filed as bugs. I doubt that this feature will be implemented in a proprietary 
way for Mozilla skins. Marking WONTFIX. 

If you feel strongly about it, reopen and assign to yourself or 
nobody@mozilla.org
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.