On OS X, run all plugins OOP by default when in 32-bit mode (i386/x86)

RESOLVED FIXED in seamonkey2.21

Status

SeaMonkey
Preferences
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

Trunk
seamonkey2.21
x86
Mac OS X

SeaMonkey Tracking Flags

(seamonkey2.20 fixed, seamonkey2.21 fixed, seamonkey2.22 unaffected)

Details

Attachments

(1 attachment)

1.85 KB, patch
Ian Neal
: review+
stefanh
: feedback+
neil@parkwaycc.co.uk
: approval-comm-aurora+
Details | Diff | Splinter Review
(Assignee)

Description

4 years ago
From Bug 863830 Comment 0:

> As a first step, let's make all plugins run OOP in 32-bit mode, without 
> exceptions, and see what happens.  This should happen first on trunk, and 
> should graduate to other branches as part of the normal, 6 week release cycle. 

> In other words, the progress of this change onto the branches shouldn't be 
> accelerated.

> If we find any 32-bit plugins that need to run in-process, we can consider 
> making exceptions for them.
(Assignee)

Comment 1

4 years ago
Created attachment 762826 [details] [diff] [review]
Patch v1.0

Need some feedback from someone on OS X hence Stefan.
Attachment #762826 - Flags: feedback?(stefanh)

Comment 2

4 years ago
Comment on attachment 762826 [details] [diff] [review]
Patch v1.0

Makes sense to me.
Attachment #762826 - Flags: feedback?(stefanh) → feedback+
(Assignee)

Comment 3

4 years ago
> Makes sense to me.
Yes. But does it have the expected effect on OS X? I can't test obviously.
Flags: needinfo?(stefanh)

Comment 4

4 years ago
I can't test the patch since my build is a pure 64-bit, but with a nightly I can see that the Google Earth plugin runs its own process if I set the 'dom.ipc.plugins.enabled.i386' pref to true and restart in 32-bit mode.
Flags: needinfo?(stefanh)
(Assignee)

Comment 5

4 years ago
Comment on attachment 762826 [details] [diff] [review]
Patch v1.0

OK, thanks Stefan. Over to IanN.
Attachment #762826 - Flags: review?(iann_bugzilla)

Updated

4 years ago
Attachment #762826 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 6

4 years ago
Comment on attachment 762826 [details] [diff] [review]
Patch v1.0

[Approval Request Comment]
Regression caused by (bug #): N/A Referenced Firefox Bug 863830 landed on mozilla23
User impact if declined: 32bit plugins aren't run as OOP. Buggy plugins can crash SeaMonkey if they aren't run in a separate process.
Testing completed (on m-c, etc.):  Tested and baked on m-c since 2013-04-25
Risk to taking this patch (and alternatives if risky): low to none since:

Bug 863830 Comment 0:
> We've since dropped support for the QuickDraw drawing model (in FF 18) and
> the Carbon event model (in FF 19)

Any remaining 32bit plugins should be able to run OOP.

String changes made by this patch: None.
Attachment #762826 - Flags: approval-comm-aurora?
(Assignee)

Comment 7

4 years ago
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/d24d0ef7532c
a=Callek CLOSED TREE
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.21

Updated

4 years ago
Attachment #762826 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Assignee)

Comment 8

4 years ago
> neil@parkwaycc.co.uk 2013-07-21 03:43:59 PDT
> Attachment #762826 [details] [diff] - Flags: approval-comm-aurora? → approval-comm-aurora+
This rode the trains and landed on aurora already:
https://hg.mozilla.org/releases/comm-aurora/rev/d24d0ef7532c

Comment 9

4 years ago
Comment on attachment 762826 [details] [diff] [review]
Patch v1.0

[Triage Comment]
a=me for comm-beta
Attachment #762826 - Flags: approval-comm-beta+
(Assignee)

Comment 10

4 years ago
Pushed to comm-beta:
https://hg.mozilla.org/releases/comm-beta/rev/4b022ddb9be4
status-seamonkey2.20: --- → fixed
status-seamonkey2.21: --- → fixed
status-seamonkey2.22: --- → unaffected
You need to log in before you can comment on or make changes to this bug.