Update Application icon and in-content Firefox icons

VERIFIED FIXED in Firefox 24

Status

()

defect
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: ibarlow, Assigned: shilpanbhagat)

Tracking

(Blocks 1 bug)

24 Branch
Firefox 25
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox23- wontfix, firefox24+ verified, firefox25+ verified)

Details

Attachments

(2 attachments)

Posted file graphic assets
Now that the refresh of the Firefox icon is complete (thanks mart3ll!), we should update the graphics we are using in Firefox for Android. 

This bug is to update the application icons for Firefox, Firefox Beta, Aurora and Nightly, as well as the large in-content icons used on about:home and about:firefox. 

All the relevant graphics are included in the attached zip file. Marking this as targeting Firefox 24 as per discussions we've had over email.
Assignee: nobody → sbhagat
Blocks: 884885
Tracking? Not sure if these changes are supposed to track on a planned channel release or something
tracking-fennec: --- → ?
Aiming for Firefox 24.
Comment on attachment 767400 [details] [diff] [review]
Replacing old graphics with new application and firefox in content icons

Review of attachment 767400 [details] [diff] [review]:
-----------------------------------------------------------------

Tested Fennec and Beta builds with these and everything seems fine. These look pretty.
Attachment #767400 - Flags: review?(wjohnston) → review+
Depends on: 889858
Comment on attachment 767400 [details] [diff] [review]
Replacing old graphics with new application and firefox in content icons

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New icons! 
User impact if declined: Visual impact will be high, new icons. 
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Low, replacing existing icons and graphics
String or IDL/UUID changes made by this patch: None
Attachment #767400 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/a9329f507dbe
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Why has the target milestone moved to Fx 25? Is there a reason we can't achieve Fx 24?

Thanks,
Karen
(In reply to Karen Rudnitski [:kar] from comment #8)
> Why has the target milestone moved to Fx 25? Is there a reason we can't
> achieve Fx 24?
> 
> Thanks,
> Karen

Target Milestones are used in engineering to designate the version that it landed to m-c in. We're approving for FF24, any reason not to approve for FF23 (beta)?
Attachment #767400 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 767400 [details] [diff] [review]
Replacing old graphics with new application and firefox in content icons

[Triage Comment]
Let's get this on Beta as well.
Attachment #767400 - Flags: approval-mozilla-beta+
Actually, the Fx24 release is aligned with overall marketing PR/branding/strategies related to FxOS. Uplifting to just Aurora but not Beta is preferable.
Comment on attachment 767400 [details] [diff] [review]
Replacing old graphics with new application and firefox in content icons

Nevermind then, we'll wait for FF24
Attachment #767400 - Flags: approval-mozilla-beta+
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.