Extra tab created when opening URL from external application.

UNCONFIRMED
Unassigned

Status

()

Firefox
Tabbed Browser
UNCONFIRMED
5 years ago
3 years ago

People

(Reporter: John Kitz, Unassigned)

Tracking

35 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

1. Start FF.
2. Click URL in another application, such as an email client or an RSS reader.



Actual results:

Results in the URL opening in a new tab, the empty tab that FF started with remains empty.


Expected results:

The URL should have opened in the empty tab that FF started with.
(Reporter)

Comment 1

5 years ago
Submitted this issue, albeit in a slightly different form, before (see bug 658774). However bug 658774 was marked duplicate of bug 440093 and closed. Looking at the comments in bug 440093 it would seem the resolution of it is impeded by some (internal) grievance. Thought this would draw attention to the, judging from the information in bug 440093, long standing and from a user perspective still open issue.

Comment 2

5 years ago
Thanks for taking the time to report this!
Haven't seen this lately.

Does the problem still happen if you start Firefox in Safe Mode? (Safe Mode disables extensions and themes, hardware acceleration and some JavaScript stuff in order to exclude some possible reasons for problems. It does not disable plugins which are add-ons.) See http://support.mozilla.com/en-US/kb/Safe+Mode 

And does this also happen with a new and empty profile? See http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile and http://support.mozilla.org/kb/Managing%20profiles . 

If you still see this problem in the new profile, please enter the address "about:support" in the address bar and attach (using the "Add an attachment" link above) the output for your original profile (not the new profile), as the "Modified Preferences" section could be interesting. 
Thanks for your help!
Flags: needinfo?(John.Kitz)
(Reporter)

Comment 3

5 years ago
(In reply to Andre Klapper from comment #2)
> Does the problem still happen if you start Firefox in Safe Mode?

Yes, it does.

Please note that the documentation (@ http://support.mozilla.com/en-US/kb/Safe+Mode) re. going into safe mode is incorrect, since the Firefox button is only shown when IN safe mode and not when in normal mode.

> And does this also happen with a new and empty profile?

Don't know and won't try as I use FF quite regularly and while I consider the behavior mentioned in this ticket as inconsistent and somewhat annoying I wouldn't classify it as "(...) having major problems (...)" which would require the use of the "Reset Firefox" option possibly causing further issues.
Flags: needinfo?(John.Kitz)
(Reporter)

Comment 4

5 years ago
Although the status of this ticket is still UNCO the problem it describes disappeared with the upgrade to release 26.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Updated

5 years ago
Resolution: INVALID → WORKSFORME
(Reporter)

Comment 5

4 years ago
Using most recent GA release, noticed the pbm. described above again today.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Updated

4 years ago
Version: 21 Branch → 30 Branch
(Reporter)

Comment 6

3 years ago
There seems to be some consistency in the occurrence of the pbm. in that it does NOT occur when Firefox hasn't been started prior to clicking an hyperlink in an external application such as an email program and it DOES occur if Firefox has been started prior to doing so as described in the description of this bug report. I hope this additional information is useful in resolving this permanently.
(Reporter)

Updated

3 years ago
Version: 30 Branch → 35 Branch

Updated

3 years ago
Component: Untriaged → Tabbed Browser
You need to log in before you can comment on or make changes to this bug.