http://getpocket.com/ bookmarklet breaks with Mixed Content Blocker

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: strugee, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Whiteboard: [mcb-ie?], URL)

(Reporter)

Description

5 years ago
STR:
1. Go to http://getpocket.com/add
2. Install the bookmarklet (click "or get the bookmarklet" and drag +Pocket to bookmark bar)
3. Go to any webpage
4. Click on the bookmarklet in your bookmarks bar

Reproducible: always

Note that when you click the doorhanger and allow mixed content for the domain, the bookmarklet still doesn't load. Should probably be a followup
(Reporter)

Updated

5 years ago

Comment 1

5 years ago
Matt, can you check this out and see why the bookmarklet is not working?  Is it broken on just HTTPS pages (because the bookmarklet tries to load insecure content?) or also on HTTP pages (which would be odd)?

Also, can you check IE and Chrome?

Not sure why the bookmarklet doesn't load after you "disable protection".  Does the bookmarklet cause a whole page reload?  Mixed Content Blocker does not persist across refreshes/page reloads.
I'm unable to reproduce.

If there is a particular site that exhibits this behavior, please tell us.

I'm able to use the bookmarklet to save both HTTP and HTTPS sites with no mixed content warning.
(Reporter)

Comment 3

5 years ago
Whoops, shouldn't have said any page.
Seems to only happen with HTTPS pages. I'm looking at https://en.wikipedia.org/wiki/Dave_Winer and it still happens with today's Nightly (2013-6-24).
Note that I have HTTPS Everywhere installed and enabled.
(Reporter)

Comment 4

5 years ago
Filed 886663 as a followup to the second part of this report.

Updated

4 years ago
Whiteboard: [mcb-ie?][mcb-chrome?]
Seems to work fine on on FF m-c nightly and Chrome 26. I used the URL from comment 3 and others.

The functionality doesn't appear to work on IE10. Perhaps it's not supported there? I try to sign in, install via drag/drop, but nothing happens.
Whiteboard: [mcb-ie?][mcb-chrome?] → [mcb-ie?]

Comment 6

4 years ago
(In reply to Matt Wobensmith from comment #5)
> Seems to work fine on on FF m-c nightly and Chrome 26. I used the URL from
> comment 3 and others.
> 

They seem to have updated their bookmarklet.  The script they source is now over https:
s.src='https://getpocket.com/b/r4.js?h='...

Getting an updated version of their bookmarklet should fix the issue.  Alex, can you try that?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

4 years ago
(In reply to Tanvi Vyas - out until 9/4 [:tanvi] from comment #6)
> (In reply to Matt Wobensmith from comment #5)
> > Seems to work fine on on FF m-c nightly and Chrome 26. I used the URL from
> > comment 3 and others.
> > 
> 
> They seem to have updated their bookmarklet.  The script they source is now
> over https:
> s.src='https://getpocket.com/b/r4.js?h='...
> 
> Getting an updated version of their bookmarklet should fix the issue.  Alex,
> can you try that?

Sorry, totally missed this question.
The updated bookmarklet fixes the issue for me.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.