Closed Bug 883772 Opened 7 years ago Closed 7 years ago

[MMS] Sending MMS: behavior when data off

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 862764
1.1 QE3 (26jun)
blocking-b2g leo+

People

(Reporter: noemi, Assigned: kchang)

References

Details

(Whiteboard: MMS_TEF, TaipeiWW)

The current behavior when data off is as follows:
1. when 'mms(apn, user, pwd)' is equal to 'data (apn, user, pwd)' then MMS is not sent
2. when 'mms(apn, user, pwd)' is different from 'data (apn, user, pwd)' then MMS is sent

The expected MMS behavior when data off should be based on the customization defined in Bug 883746
Depends on: 883746
Nominating to leo? in order to have enough flexibility to adapt to different markets and pricing schemas
blocking-b2g: --- → leo?
Whiteboard: MMS_TEF
Summary: [MMS] MMS behavior when data off → [MMS] Sending MMS behavior when data off
Summary: [MMS] Sending MMS behavior when data off → [MMS] Sending MMS: behavior when data off
Assignee: nobody → kchang
blocking-b2g: leo? → leo+
Target Milestone: --- → 1.1 QE3 (24jun)
Just clarifying that the expected behavior for TEF when data off is that MMS will be transparently sent (without user interaction), no matter whether mms (apn, usr,pwd) is equal to data (apn,usr, pwd) or whether user is in roaming or not. Notice that it will block certification process.
Whiteboard: MMS_TEF → MMS_TEF, TaipeiWW
If we want to track the customization feature, the bug 883746 will be enough for tracking.
If we want to track the problem of that MMS cannot be sent when MMS shares the same apn with data and data is not enable, the bug 862764 will be enough for tracking. So I mark this bug as duplicate of bug 862764.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862764
You need to log in before you can comment on or make changes to this bug.