[email] Reply-to-all does not filter out the active account's own e-mail address from recipient lists

VERIFIED FIXED in Firefox OS v1.4

Status

P2
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: mdavydova, Assigned: mcav)

Tracking

unspecified
1.4 S6 (25apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.4+, b2g18+, b2g-v1.3T affected, b2g-v1.4 fixed, b2g-v2.0 fixed)

Details

(Whiteboard: permafail [p=1])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 763836 [details]
Screenshots

Description
When user receives an email with more then 1 recipient and taps on the "Reply to all" button, the new email compose message with original text opens up. However, the email address of the sender still appears in the recipients list.

Repro Steps:
1) Updated to Leo Build ID: 20130610070206
2) Set up an email account on the device
3) Open an email from the account's Inbox which has more then 1 recipient and has at least 1 in both the "To" and the "CC" fields
4) Tap the Reply All button
5) Verify that the email sender address does not appear in the recipients list

Actual:
The email sender address appears in the recipients list

Expected:
The email sender address does not appear in the recipients list

Environmental Variables
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8e3f39363c54
Gaia: ce3b99781d182ad550a325206990c249b0dbcf0e
Platform Version: 18.0

Notes:
Repro frequency: 100
Test Suite Name: Email
UCID: (email-117)
Link to failed test case: https://moztrap.mozilla.org/runtests/run/1475/env/314/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=4390
Q Analysts Team Priority: Pri 3
See attached: screenshots for more info

Updated

6 years ago
blocking-b2g: --- → leo?
Comment 0's use of the term "sender address" is ambiguous because there are two special e-mail addresses in this situation to whom it could apply:
1) The e-mail address of the author of the received message (who sent the message).
2) The e-mail address of the active e-mail account (who will send the reply).

We currently avoid adding case 1 to the recipients list if they are already present on the list, but we make no effort to address case 2 by filtering out recipients.  This is a bug and inconsistency on our part; Thunderbird does perform the filtration step.
Summary: [B2G][Email] Email sender address appears in the recipient list, when user selects "Reply to all" option → [email] Reply-to-all does not filter out the active account's own e-mail address from recipient lists

Comment 2

6 years ago
We should slate this enhancement for v1.2 or later. Not a blocker for v1.1.
blocking-b2g: leo? → -
tracking-b2g18: --- → +

Updated

6 years ago
Priority: -- → P2
Target Milestone: --- → 1.1 QE4 (15jul)

Updated

6 years ago
Whiteboard: leorun3 → leorun3, leorun4
(clearing QE4 target because it's not leo+)

Updated

5 years ago
Whiteboard: leorun3, leorun4 → leorun3, leorun4, retest_leorun4
Duplicate of this bug: 894837
Duplicate of this bug: 913305

Updated

5 years ago
Whiteboard: leorun3, leorun4, retest_leorun4 → leorun3, leorun4, retest_leorun4, burirun1
Whiteboard: leorun3, leorun4, retest_leorun4, burirun1 → leorun3, leorun4, retest_leorun4, burirun1, burirun3

Updated

5 years ago
Whiteboard: leorun3, leorun4, retest_leorun4, burirun1, burirun3 → permafail
still reproducible on latest V1.2 and V1.3

buri V1.2 build
Gaia:     075e60c878b0eca68fba9e00bc85cb6eac03578a                         
Gecko:                                                                     
http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/14868788d50e         
BuildID   20131202004001                                                   
Version   26.0                                                             
ro.build.version.incremental=eng.archermind.20131114.105818  

buri V1.3 build
Gaia:     df070d4eed244e782dd3a7c2a7586d0741eac09f                         
Gecko:    http://hg.mozilla.org/mozilla-central/rev/9ac7ed427cd2           
BuildID   20131203151100                                                   
Version   28.0a1                                                           
ro.build.version.incremental=eng.zxliu.20131101.143946
blocking-b2g: - → backlog

Updated

5 years ago
blocking-b2g: backlog → 1.3?
Not a regression, so this is not a blocker.
blocking-b2g: 1.3? → backlog

Comment 8

5 years ago
This is potential blocker of IOT
blocking-b2g: backlog → 1.3?
What's the expected functionality? Not sure if its designed this way. Adding product to help with understanding the same.
Flags: needinfo?(ffos-product)
(In reply to Preeti Raghunath(:Preeti) from comment #9)
> What's the expected functionality? Not sure if its designed this way. Adding
> product to help with understanding the same.

Quoting comment 1:

===
Comment 0's use of the term "sender address" is ambiguous because there are two special e-mail addresses in this situation to whom it could apply:
1) The e-mail address of the author of the received message (who sent the message).
2) The e-mail address of the active e-mail account (who will send the reply).

We currently avoid adding case 1 to the recipients list if they are already present on the list, but we make no effort to address case 2 by filtering out recipients.  This is a bug and inconsistency on our part; Thunderbird does perform the filtration step.
===
Discussed via Vance - there's agreement now this isn't a blocker.
blocking-b2g: 1.3? → backlog
Flags: needinfo?(ffos-product) → needinfo?(wmathanaraj)
Duplicate of this bug: 993943
Due to it is a really bad user experience nominating to v1.4? to be considered. Thanks!
blocking-b2g: backlog → 1.4?
this is bad user experience and should block v1.4. we need to fix this.
Flags: needinfo?(wmathanaraj)
(In reply to Andrew Sutherland (:asuth) from comment #1)
> Comment 0's use of the term "sender address" is ambiguous because there are
> two special e-mail addresses in this situation to whom it could apply:
> 1) The e-mail address of the author of the received message (who sent the
> message).
> 2) The e-mail address of the active e-mail account (who will send the reply).
> 
> We currently avoid adding case 1 to the recipients list if they are already
> present on the list, but we make no effort to address case 2 by filtering
> out recipients.  This is a bug and inconsistency on our part; Thunderbird
> does perform the filtration step.

Based on triage discussion, the concern was indeed about case 2.
Blocking for 1.4
blocking-b2g: 1.4? → 1.4+
(Assignee)

Updated

5 years ago
Assignee: nobody → m
Status: NEW → ASSIGNED
Target Milestone: 1.1 QE4 (15jul) → 1.4 S6 (25apr)
Comment on attachment 8406307 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia-email-libs-and-more/pull/301

greet! thanks!
Attachment #8406307 - Flags: review?(bugmail) → review+
(Assignee)

Comment 19

5 years ago
GELAM: https://github.com/mcav/gaia-email-libs-and-more/commit/0bc01c402132d9eb8f4b48c6b401f27c1a50426c

Gaia master: https://github.com/mcav/gaia/commit/6904deba65e6616129b981616c0f4d0e9c97be62
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-b2g-v1.4: --- → affected
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Whiteboard: permafail → permafail [p=3]
(Assignee)

Updated

5 years ago
Whiteboard: permafail [p=3] → permafail [p=1]

Updated

5 years ago
status-b2g-v1.3T: --- → affected
v1.4: https://github.com/mozilla-b2g/gaia/commit/441c4bcd8ac4f8c01a9bc5a2f8d64eaa87844803
status-b2g-v1.4: affected → fixed
status-b2g-v2.0: --- → fixed
I observed a situation that needs to be comfirmed. If I used to my gmail account send to myslf and other people, and then reply to all, I saw my gmail account does be filered out. Please see my steps below.

[Reproduce]
1. Set a gmail accout_1 
2. Send a mail to other people and self with account_1
3. Go to account_1 inbox to check this mail
4. Reply to all
5. You can see the account_1 has been filter out in recipient list that means the recipient listis empty . This is a little bit strange. 


[Environment]
Gaia      3d47c0627017ef77b1adf179792c6543a349af72
Gecko     https://hg.mozilla.org/mozilla-central/rev/1f932e462b84
BuildID   20140415160202
Version   31.0a1
ro.build.version.incremental=eng.archermind.20131114.105818
ro.build.date=Thu Nov 14 10:58:33 CST 2013


[Result]
PASS
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.