Closed Bug 884240 Opened 9 years ago Closed 8 years ago

m.europapress.es doesn't display correctly in Gaia browser

Categories

(Web Compatibility :: Mobile, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: efrat, Assigned: adamopenweb)

References

()

Details

(Whiteboard: [serversniff][country-es] [sitewait])

Attachments

(1 file)

Attached image europapress.jpg
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36

Steps to reproduce:

Browsed to "http://m.europapress.es/" from Gaia browser

Tested on Firefox OS simulator
OS version 1.1.0.0-prerelease
Build Identifier 20130522133646

On User Agent String:
Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36


Actual results:

In the simulator - The site uploads as a desktop site and not mobile adjusted

On a device - The site uploads as a desktop site and not mobile adjusted (same)


Expected results:

The web page should have been displayed
Component: Gaia::Browser → Mobile
Product: Boot2Gecko → Tech Evangelism
Version: unspecified → Trunk
A mobile site is served to Firefox for Android. Looks like they're sniffing for the "Android" token.
Confirmed. They are sniffing for the "Android" token in the UA string and sending a 302 to the desktop site if it isn't found. 

But it can't appear just anywhere, oddly, "MozillAndroid/5.0..." gets the mobile site while "...Mobile; Android;..." doesn't.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: serversniff
Whiteboard: serversniff → [serversniff][country-es]
Whiteboard: [serversniff][country-es] → [serversniff][country-es] [contactready]
Email sent to webmaster/technical department (sistemas@europapress.es)
Assignee: nobody → astevenson
Status: NEW → ASSIGNED
Whiteboard: [serversniff][country-es] [contactready] → [serversniff][country-es] [sitewait]
This website is using server side user agent detection to determine if a user is browsing using a desktop or mobile client. Unfortunately the site is not properly detecting the user agent string for mobile Firefox browsers. This is causing Firefox mobile browsers to be redirected to the desktop version of the website rather than mobile.
This is fixed.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Thanks guys. Fixed indeed.
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.