Closed Bug 884355 Opened 6 years ago Closed 6 years ago

"Warn me when closing multiple tabs" should warn when "Never remember history" is enabled

Categories

(Firefox :: Private Browsing, defect)

21 Branch
x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 29
Tracking Status
firefox29 --- verified

People

(Reporter: bugs, Assigned: nafissamajda)

References

Details

(Whiteboard: [mentor=jdm][lang=js])

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130512193848

Steps to reproduce:

In the Privacy preferences, configure Firefox to "Never remember history". Keep the default "Warn me when closing multiple tabs".

Go to some site. Middle click on a link to open a new tab. Secondary click on another link and Open Link in New Private Window. (Note that because of the Privacy setting, there's no entry to Open Link in New Window in the File menu.) Middle click on a link in this window.


Actual results:

There are now two windows with two tabs each. Close one of the windows, using the mouse or the keyboard. It closes with no warning. The remaining window will present a warning if you try to close it.

The same happens if you have two (or more) windows started from the startup window, and you closed the startup window. All windows except the last remaining window close without warning.


Expected results:

I suggest there should be consistency. My preference is that all windows should respect the "Warn me when closing multiple tabs" setting. Failing that, I suggest: (i) the last window should also close without warning; (ii) the multiple tabs setting should be greyed out.

(This follows on from bug 884241, the 8th comment. I'm making the argument.)
Updating the isPBWindow value in warnAboutClosingWindow (http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#6014) to check for permanent PB mode as well (http://mxr.mozilla.org/mozilla-central/source/toolkit/modules/PrivateBrowsingUtils.jsm#29) would fix this, I believe.
Component: Untriaged → Private Browsing
Summary: "Warn me when closing multiple tabs" fails in all but last private window → "Warn me when closing multiple tabs" should warn when "Never remember history" is enabled
Whiteboard: [mentor=jdm][lang=js]
Commits pushed to master at https://github.com/mozilla/webmaker.org

https://github.com/mozilla/webmaker.org/commit/5fbbcc52eab183e62e46a415ee4028f012f38388
[bug 884355] Mobile Homepage Tiles and Touch

https://github.com/mozilla/webmaker.org/commit/de280c0cb3762dafdce1ad2cbbddcee015b7ccea
Merge pull request #186 from daleee/884335-mobile-ux-tiles

[bug 884355] Mobile Homepage Tiles and Touch
Assignee: nobody → nafissamajda
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #766416 - Flags: review?(josh)
Comment on attachment 766416 [details] [diff] [review]
Check if Never remember history mode is on

Review of attachment 766416 [details] [diff] [review]:
-----------------------------------------------------------------

I apologize for sitting on this for so long! I think we should combine this check with the one above it, since they end up performing the same action. Could you prepare a new patch that does that?
Attachment #766416 - Flags: review?(josh) → feedback+
Attachment #766416 - Attachment is obsolete: true
Comment on attachment 780982 [details] [diff] [review]
Warn about closing multiple tabs when "Never remember history" is enabled"

I suppose this seems reasonable, but you should update the comment to explain the various cases (i.e. mention more than just popups).
Attachment #780982 - Flags: review?(gavin.sharp) → review+
Comment on attachment 780982 [details] [diff] [review]
Warn about closing multiple tabs when "Never remember history" is enabled"

>-
>+  

Avoid this change.
Looks like this was forgotten?
Flags: needinfo?(josh)
What's happening with this?
https://hg.mozilla.org/mozilla-central/rev/0c63a95e2dd8
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Keywords: verifyme
Blocks: 987821
Reproduced in Nightly 2013-06-18, win 7 x64.
Verified fixed using the STR in comment 0 on FF 29b2, Win 7 x64.
Found another issue - filed bug 987821
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.