Closed Bug 884566 Opened 7 years ago Closed 7 years ago

Don't show Bluetooth as the default Quick Share entry

Categories

(Firefox for Android :: General, defect)

24 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 25
Tracking Status
firefox24 --- verified
firefox25 --- verified

People

(Reporter: ibarlow, Assigned: sriram)

References

Details

Attachments

(1 file)

Currently the default icon in the Share menu is for Bluetooth. Quick Share should only promote share tools that a users actually uses. 

In other words by default the icon area should be blank, and only show an icon once a share service has been used.
Blocks: 869123
Attached patch PatchSplinter Review
( Thanks android for giving history size! )

This shows the default icon only if there's any his/her story.
Attachment #766944 - Flags: review?(mark.finkle)
Comment on attachment 766944 [details] [diff] [review]
Patch

You'll need to uplift this to aurora now as well
Attachment #766944 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/0767250bcb88
Assignee: nobody → sriram
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Comment on attachment 766944 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 869123
User impact if declined: Bluetooth will be shown by default.
Testing completed (on m-c, etc.): Landed on m-c on 06/26
Risk to taking this patch (and alternatives if risky): None. Checks for history size and shows a default activity if one exists.
String or IDL/UUID changes made by this patch: None.
Attachment #766944 - Flags: approval-mozilla-aurora?
Attachment #766944 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
OS: Mac OS X → Android
Hardware: x86 → ARM
Verified fixed on:
Build: Firefox for Android 24.0a2(2013-07-03)
Device: LG Nexus 4
OS: Android 4.2.2
You need to log in before you can comment on or make changes to this bug.