[Gallery] When an image is zoomed, android gives better quality than B2G

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: leo.bugzilla.gaia, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
1. Title: Zoomed Image quality is good on android device, compared to FFOS
2. Precondition: Have a android phone and a B2G phone (with the same hardware spec)
3. Tester's Action:
        1. Capture a picture from B2G phone
        2. Copy the same picture to the android phone
	3. Zoom the image
        4. Compare the quality of the image zoomed in android and B2G devices
        5. In Android phone , zoomed image has a better quality
4. Detailed Symptom (ENG.): After zooming a image,the quality is good in android phone compared to B2G device
5. Expected : Quality should be same or better than android   
6. Reproducibility: Y
1)Frequency Rate : 100%
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 032bcd8fb6eca83f701768d1ea123cc81623a6f6
(Reporter)

Comment 1

5 years ago
Hi djf,

Need your opinion on this defect.

I dont have any specific reference images.

Maybe you can take a picture from the device camera and compare(zoomed image).
(Reporter)

Updated

5 years ago
Flags: needinfo?(dflanagan)
Leo: did you wait 2 seconds after zooming and note that the image goes from fuzzy to clear? Can you explain more specifically what is low quality about the image on FFOS?  Could it be related to hardware differences in the screen quality?  (e.g. its not fair to compare an image on the Leo device with a high-end Samsung Android phone with OLED display, like the personal phone I have.)

QA: zoomed camera photos look perfectly clear to me on my Leo device. Could you see if you can reproduce this?  Note that when we zoom on FFOS, we first zoom a small image and you'll see fuzziness. Then one or two seconds later, the full-size image will be swapped in and the image will become clear again.  That is expected and not a bug.
Flags: needinfo?(dflanagan)
Keywords: qawanted
(Reporter)

Comment 3

5 years ago
Hi djf,

Yes, as you mentioned after 2 or 3 secs , the image goes from fuzzy to clear view.

What i meant by quality is when the image is zoomed fully on both the devices, and when compared the clarity of the zoomed image in android was better.

Also, iam using the same hardware.

Is there any optimal value or threshold set for zooming in B2G.So that i can try the same on android .

Thanks,
(Reporter)

Comment 4

5 years ago
Created attachment 766585 [details]
Sample image file

Hi djf,

I have attached a sample image file, which iam not able to zoom in b2g device.

Need your opinion on this image .
Flags: needinfo?(dflanagan)
The Gallery app intentionally does not allow you to zoom in on an image that is smaller than the screen. So I wouldn't expect you to be able to zoom the image that you have attached.

Gallery should never display an image at a size larger than its actual size.
Flags: needinfo?(dflanagan)
I tested with a number of images from the camera on Leo device using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/15923aca6e6d
Gaia   c7472acec84f0d4527cdd6fd555d289e1d3e1d1d
BuildID 20130701070213
Version 18.1

and I have not been able to reproduce an issue with quality and zooming. In fact, I don't even see a delay of 2-3 seconds before the images become clear. I am using the latest base image from Leo.
Keywords: qawanted

Updated

5 years ago
Blocks: 958307

Comment 7

5 years ago
Created attachment 8359049 [details]
zooming creates fuzzy image.

Hi Djf,

In the attached video , you can  notice the fuzziness after 2-3 sec of image zooming . I have used image taken from camera for testing.

Device used for testing : Leo
FFOS version: 1.3.0 prerelease.

Please share your feedback.
Attachment #8359049 - Flags: feedback?(dflanagan)
What I see in the attached video is that when you zoom the image, the preview zooms in and it is fuzzy.  Then the I see it replaced by the full-size image and it becomes much clearer than it was. That is expected and I don't consider it to be a bug.

What is the bug here?  The fact that a clear image does not appear instantly?  Or are you saying that even after 2 seconds the image is not clear enough.

If the former: when we have a fix for bug 854795, I expect that this will improve significantly.

If the latter: please provide screenshots of the same zoomed image in FirefoxOS vs. Android.  Perhaps we can use a different downsampling algorithm and get better results  Though that might require a gecko fix rather than a gaia fix... I don't know much about it.

We can't have this bug blocking bug 958307 if we can't even understand what the bug is!
Comment on attachment 8359049 [details]
zooming creates fuzzy image.

Clearing the feedback flag.

Ranjith: normally we use feedback? to ask for comments on a patch. In this case, setting needinfo? would have been the right way to ask for my comments on the new video.  (It doesn't matter much; that's just the convention we use)
Attachment #8359049 - Flags: feedback?(dflanagan)

Comment 10

5 years ago
> 
> What is the bug here?  The fact that a clear image does not appear
> instantly?  Or are you saying that even after 2 seconds the image is not
> clear enough.
   The former one is my bug.
> If the former: when we have a fix for bug 854795, I expect that this will
> improve significantly.
  By looking at the status of bug 854795 its still new,I may have to wait for the issue to be  resolved  & uplifted to master.Till that time I can have bug 958307 as blocking.
> We can't have this bug blocking bug 958307 if we can't even understand what
> the bug is!
Bug 854795 has been fixed for a little while now, can you verify that resolved your problem here?
Flags: needinfo?(ranjithatbugzilla)

Comment 12

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.