Thunderbird tries to create INBOX.Sent folder but the sent copy folder is a different one

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: zimpel, Unassigned)

Tracking

x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

I've configured a custom copy folder for sent mails (INBOX.Gesendet instead of INBOX.Sent) according to the folder structure of the IMAP-Account our mail hoster provides.


Actual results:

When sending a new message, everything is ok. The sent mail is copied into the configured folder (INBOX.Gesendet). But if I reply to some of my existing mails, Thunderbird tries to create an INBOX.Sent folder (which does not exist and the provider does not allow creating new IMAP folders at the root level). So "copy to sent folder" fails with an error message. Deleting the IMAP-Cache has had no effect.

See the log file:

7288[85017d0]: e5a8c00:ssl0.ovh.net:A:CreateNewLineFromSocket: 4 NO [TRYCREATE] Mailbox doesn't exist: INBOX.Sent


Expected results:

The sent mail must be stored into the custom copy to send folder as configured under Account Settings / Copies and Folders / Other.
(Reporter)

Updated

5 years ago
OS: Mac OS X → Windows 7

Updated

5 years ago
Component: Folder and Message Lists → Networking: IMAP
Product: Thunderbird → MailNews Core

Comment 1

5 years ago
Is the replied to message a recent one and in the same IMAP account? Can you view the source of it (Ctrl-U) and check if the Account-Key is really the account in which you set the custom Sent folder?
(In reply to Helge-Frank Zimpel from comment #0)
> Steps to reproduce:
> I've configured a custom copy folder for sent mails (INBOX.Gesendet instead of INBOX.Sent) (snip)

"What operation at where" do you call by "I've configured a custom copy folder for sent mails".

FYI.
In Tb, "folder to save sent mail copy" is defined at Copies&Folders of each Identity, and there is option of "save in original folder when Reply" in each Copies&Folders of each Identity.
There may be bug of "some settings of default identity=first identity is not correctly saved if set via per identity Copies&Folders". If such bug occurs, set it via "main Copies&Folders shown at Accout Settings" instead of "via per identity Copies&Folders setting".

> Actual results:
> When sending a new message, everything is ok.
> The sent mail is copied into the configured folder (INBOX.Gesendet). > But if I reply to some of my existing mails, Thunderbird tries to
> create an INBOX.Sent folder (which does not exist and the provider
> does not allow creating new IMAP folders at the root level).

In Tb, there is no difference between "send of new mail" and "send of reply mail" in "sending of mail" and "saving sent mail copy to folder to save sent mail copy", except in "sent folder selection upon Reply by your request in Copies&Folders setting".
Tb always determines "folder to save sent mail copy" from Identity used by the mail sending(From: mail address of New or Reply mail).

Is all Identities's "folder to save sent mail copy" in Copies&Folder set as the "INBOX.Gesendet" which you want?

Do you use loalized Tb?
If yes, is "Gesendet" localized name of "Sent" in en-US?
If so, string of "Sent" in internal setting may be shown as "Gesendet" at UI of Tb...

Because INBOX.Sent doesn't exist at your IMAP server, and INBOX.Gesendet(actually "Gesendet" at server) exist at server, "Gesendet under IBOX shown at folder selection UI of Tb" is the INBOX.Gesendet(actually "Gesendet" at server).
Please select INBOX.Gesendet via "Others:" of each Identity's Copies&Folders setting, if "Gesendet" is localized name of "Sent" in en-US.
(Reporter)

Comment 3

5 years ago
Thank you for your advice. I was not aware of the fact that the identities also have copies&folder settings. The identity was created before configuring the main copies&folder settings. So the folder to save the sent mail copy for the identity did not exist.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

5 years ago
Resolution: WORKSFORME → INVALID
You need to log in before you can comment on or make changes to this bug.