Assertion failure: data.s.payload.why == why, at dist/include/js/Value.h

RESOLVED FIXED in mozilla24

Status

()

defect
--
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: gkw, Unassigned)

Tracking

(Blocks 1 bug, {assertion, regression, testcase})

Trunk
mozilla24
x86_64
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jsbugmon:update])

Attachments

(1 attachment)

Posted file stack
(function() {
    "".replace("", b => {
        return eval("[arguments]")
    })
})()

asserts js debug shell on m-c changeset c12150cfdfef without any CLI arguments at Assertion failure: data.s.payload.why == why, at dist/include/js/Value.h
autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   http://hg.mozilla.org/mozilla-central/rev/bf3ce88c6ea3
user:        Jason Orendorff
date:        Sun Mar 17 20:42:36 2013 -0700
summary:     Bug 846406 - Implement arrow functions. r=bhackett. Changes to Y.js r=brendan.
Blocks: 846406
Flags: needinfo?(jorendorff)
The patch in bug 852762 fixes this.
Flags: needinfo?(jorendorff)
It was due to arguments not existing in arrow functions, which bug 852762 backs out.
https://hg.mozilla.org/mozilla-central/rev/e32ba820b8ce
https://hg.mozilla.org/mozilla-central/rev/d38da575ace4
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Duplicate of this bug: 885934
You need to log in before you can comment on or make changes to this bug.