Closed Bug 885089 Opened 7 years ago Closed 7 years ago

Opening the emtpy MMS message crashes the phone

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, critical)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(blocking-b2g:leo+)

RESOLVED DUPLICATE of bug 883296
blocking-b2g leo+

People

(Reporter: anshulj, Assigned: ctai)

Details

(Keywords: crash, Whiteboard: [b2g-crash])

Attachments

(1 file)

Using a setcom test box send an MMS with emtpy payload. Wait for the UI notification for the incoming MMS. Click on the notification to go to the message.

Observed that the phone restarts. This test is part of the certification suite for MMS run by QC.
Is this bug duplicate bug 883296? Bug 883296 is r+ now. Should be landed soon.
Flags: needinfo?(anshulj)
Severity: normal → critical
Keywords: crash
Whiteboard: [b2g-crash]
Anshul,
Can you also provide your attachment in the MMS? Actually I don't 100% sure what you mean about empty payload. In the log, it shows "content-length":0 and "content":null in the parts. Looks very like bug 883296. Now bug 883296 is landed on birch. Should be landed in b2g18 very soon. Please test it again when bug 883296 is landed.
Let's try to prevent this DoS
blocking-b2g: leo? → leo+
CTai, the bug 883296 does sound like this bug. Will let and let you know.
Flags: needinfo?(anshulj)
Mark as resolved.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 883296
You need to log in before you can comment on or make changes to this bug.