lightning is not accepting invitations

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: tbee, Unassigned)

Tracking

Lightning 1.9.1
x86
Windows XP

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36

Steps to reproduce:

Forwarded an outlook invitation to Thunderbird 17.0.6. I've got Lightning 1.9.1, Google Calendar plugin 0.18 and several calendars setup. Removed and re-added the calendar associated withe the email address where the invitation was send to.


Actual results:

Invite is recognized "Message contains an invitation to an event" but no accept buttons are show. The error console lists this:

Timestamp: 2013-06-20 16:34:58
Error: [Exception... "'TypeError: this.mItipItem.targetCalendar is null' when calling method: [nsIObserver::observe]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "JS frame :: file:///M:/data/Thunderbird/Profiles/tluw26db.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/lightningTextCalendarConverter.js :: lmcCTH :: line 273"  data: no]
Source File: file:///M:/data/Thunderbird/Profiles/tluw26db.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/lightningTextCalendarConverter.js
Line: 273



Expected results:

Accept buttons should have been shown.

Updated

5 years ago
Component: Untriaged → Lightning Only
Product: Thunderbird → Calendar
Version: 17 → Lightning 1.9.1

Updated

5 years ago
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)

Comment 1

5 years ago
Did you try to import the event to your Google Calendar?
These do not support invitation, and at least in recent version it should be impossible to choose them as the target calendar. Does the issue still exist, does the error still come up in Error Console?

Comment 2

5 years ago
Thunderbird 24.2.0 + Lightning 2.6.4
All invitations lack accept buttons, but show "Message contains an invitation to an event".

Error console shows:
foundAttendee is null
resource://calendar/modules/calitipUtils.jsm

Comment 3

5 years ago
TC, you are referring the problem discussed in Bug 927346.

Comment 4

4 years ago
Tom, is this still an issue for you in Lightning 3.3.x?
(Reporter)

Comment 5

4 years ago
I kinda gave up on getting TB to accept invitations and modify my calendar manually. 

But coincidentally I looked into it again yesterday and changed the "enableEmailInvitations" in an attempt to relight the effort. Currently I'm using an Ubuntu system at work and it would be great to be able to accept Outlook invitations. So is it working now: no. But I hope to have more information soon.

Comment 6

4 years ago
Do you use Google calendar, another calendar server or a local calendar? If the first: via CalDAV or the Google provider? Which versions are you currently using? If there's a message in the error console, please post it as well.
(Reporter)

Comment 7

4 years ago
Well, I have got it working now. The most important steps were:
- setup a remote calendar using the iCal instead of the Google Calendar provider.
  https://apidata.googleusercontent.com/caldav/v2/<your email address>/events
- set enableEmailInvitations to true

The last action requires the use of "advanced" settings. But since this is such a common requirement, it really should not.
A few questions remain; 
- is the Google Calendar provider plugin still needed when using iCal?
- The specified "v2" url does not specify what Google calendar to use, I have multiple, how does it know which calendar to use? I tried using the iCal URLs on the calendar's settings page, but that does not seem to work.
Provider for Google Calendar doesn't support invitations. Therefore you can't use its calendars for invitations.

The URL you are using means that you are using CalDAV access and not ICS access. Be sure to use the correct CalDAV option when creating the calendar in Lightning.

Read more on how to get the address for all of your calendars on <https://developers.google.com/google-apps/calendar/caldav/v2/guide#connecting_to_googles_caldav_server>

Comment 9

4 years ago
The enableEmailInvitations preference is used for Google provider only. If you use Caldav to access for Google calendar, you don't need the Google provider at all.

Resolving this to WFM as per comment #7.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.