Closed Bug 885347 Opened 9 years ago Closed 9 years ago

On Firefox 22 - the update channel reference is missing from the about dialog

Categories

(Firefox :: General, defect)

22 Branch
x86
All
defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox22 - ---

People

(Reporter: simona.marcu, Unassigned)

Details

Attachments

(2 files)

Attached image about dialog
Mozilla/5.0 (Windows NT 6.0; rv:22.0) Gecko/20100101 Firefox/22.0
Build ID: 20130619132145

The reference to the update channel that is set as default (You are currently on the release update channel) is missing in Firefox 22 RC (please see the attached screenshot).

The issue is not reproducible on the latest Nightly, on the latest Aurora, on Firefox 21 RC and on Firefox 22 beta 6.
Summary: The update channel reference is missing in Firefox 22 in the about dialog → On Firefox 22 - the update channel reference is missing from the about dialog
rstrong is likely the best person to take a look. Does this impact update functionality, or is it merely not reporting the issue? I double checked the fact that we fixed the update channel on the beta->release merge - https://hg.mozilla.org/releases/mozilla-release/rev/574a39cdf657
Assignee: nobody → robert.bugzilla
Does this impact update functionality, or is it merely not reporting the *channel*?
Flags: needinfo?(simona.marcu)
Flags: needinfo?(jbecerra)
I talked with akeybl on irc regarding priorities and won't be looking at this bug anytime soon unless the answer to comment #2 is yes.
I haven't seen any problems during updates testing in the beta cycle leading up to the RC, and it just seems like it isn't displaying the "You are currently on the release update channel" string.
Flags: needinfo?(jbecerra)
I suspect bug 848451. cc'ing appropriate people from that bug and reassigning to default.
Assignee: robert.bugzilla → nobody
Yes, this is working as intended.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
(In reply to Alex Keybl [:akeybl] from comment #2)
> Does this impact update functionality, or is it merely not reporting the
> *channel*?

The update is properly done, the *channel* in the about dialog is the reason why this bug was filed.
(In reply to Jared Wein [:jaws] from comment #6)
> Yes, this is working as intended.

I previously changed the update channel from *release* to *betatest* and I don't see any reference in the about dialog regarding the update channel. Is this still expected?
Flags: needinfo?(simona.marcu)
(In reply to Simona B [QA] from comment #8)
> Created attachment 765845 [details]
> about dialog with a non-default update channel
> 
> (In reply to Jared Wein [:jaws] from comment #6)
> > Yes, this is working as intended.
> 
> I previously changed the update channel from *release* to *betatest* and I
> don't see any reference in the about dialog regarding the update channel. Is
> this still expected?

I'm confused - how exactly did you get into this state? Can you list the STR?
Flags: needinfo?(simona.marcu)
We determine if we are going to show the update channel at build time. If you change the update channel after Firefox has been compiled and packaged, the About dialog will not being showing the update channel.
(In reply to Mike Conley (:mconley) from comment #9) 
> I'm confused - how exactly did you get into this state? Can you list the STR?

The first time that I saw that the update channel was missing was after updating from Firefox 21 RC (the betatest channel was open)
STR:
1. Install Firefox 21 RC
2. In the default folder located in the installation folder, change the update channel to *betatest* 
3. Launch Firefox 21, open the About Firefox dialog and after the updates are downloaded click on the "Restart to Update"  button.
Flags: needinfo?(simona.marcu)
You need to log in before you can comment on or make changes to this bug.