Closed Bug 885394 Opened 6 years ago Closed 6 years ago

crash in js::StackFrame::initExecuteFrame

Categories

(Core :: JavaScript Engine, defect, critical)

24 Branch
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 881902
Tracking Status
firefox23 --- unaffected
firefox24 + fixed

People

(Reporter: scoobidiver, Unassigned)

References

Details

(Keywords: crash, regression, topcrash)

Crash Data

It first showed up in 24.0a1/20130620. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d2a7cfa34154&tochange=8ea92aeab783
It's likely a regression from bug 882111.

Signature 	js::StackFrame::initExecuteFrame(JSScript*, js::StackFrame*, js::AbstractFramePtr, js::FrameRegs*, JS::Value const&, JSObject&, js::ExecuteType) More Reports Search
UUID	e443356c-6f14-4b74-bbc6-668252130620
Date Processed	2013-06-20 16:09:01
Uptime	4224
Last Crash	3.2 hours before submission
Install Age	1.7 hours since version was first installed.
Install Time	2013-06-20 14:26:00
Product	Firefox
Version	24.0a1
Build ID	20130620031010
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 15 stepping 6
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x38
App Notes 	
AdapterVendorID: 0x10de, AdapterDeviceID: 0x10c3, AdapterSubsysID: 13023842, AdapterDriverVersion: 9.18.13.1422
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ WebGL? EGL? EGL+ GL Context? GL Context+ WebGL+ 
Processor Notes 	sp-processor04_phx1_mozilla_com_29267:2012
EMCheckCompatibility	True
Adapter Vendor ID	0x10de
Adapter Device ID	0x10c3
Total Virtual Memory	4294836224
Available Virtual Memory	3507875840
System Memory Use Percentage	83
Available Page File	2889592832
Available Physical Memory	900788224

Frame 	Module 	Signature 	Source
0 	mozjs.dll 	js::StackFrame::initExecuteFrame 	js/src/vm/Stack.cpp:60
1 	mozjs.dll 	js::ContextStack::pushExecuteFrame 	js/src/vm/Stack.cpp:952
2 	mozjs.dll 	js::ExecuteState::pushInterpreterFrame 	js/src/vm/Interpreter.cpp:369
3 	mozjs.dll 	Interpret 	js/src/vm/Interpreter.cpp:1097
4 	mozjs.dll 	js::ion::CanEnter 	js/src/ion/Ion.cpp:1708
5 	mozjs.dll 	js::RunScript 	js/src/vm/Interpreter.cpp:411
6 	mozjs.dll 	js::ExecuteKernel 	js/src/vm/Interpreter.cpp:595
7 	mozjs.dll 	js::DirectEvalFromIon 	js/src/builtin/Eval.cpp:398
8 	mozjs.dll 	mozjs.dll@0x2d4a48 	

More reports at:
https://crash-stats.mozilla.com/report/list?signature=js%3A%3AStackFrame%3A%3AinitExecuteFrame%28JSScript*%2C+js%3A%3AStackFrame*%2C+js%3A%3AAbstractFramePtr%2C+js%3A%3AFrameRegs*%2C+JS%3A%3AValue+const%26%2C+JSObject%26%2C+js%3A%3AExecuteType%29
It's #4 top crasher in today's build.
Keywords: topcrash
OS: Windows 7 → All
Hardware: x86 → All
I'm pretty sure bug 881902 will fix this (on inbound now).
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 881902
You need to log in before you can comment on or make changes to this bug.