Last Comment Bug 885517 - Plugin CTP request: Update latest Flash CTP list to 11.7.700.169
: Plugin CTP request: Update latest Flash CTP list to 11.7.700.169
Status: VERIFIED FIXED
[plugin]
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: All All
: -- normal with 2 votes (vote)
: 2013-07-04
Assigned To: Jorge Villalobos [:jorgev]
: Anthony Hughes (:ashughes) [GFX][QA][Mentor]
Mentors:
: 885518 (view as bug list)
Depends on: 1163252
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 13:55 PDT by Alex Keybl [:akeybl]
Modified: 2016-03-07 15:30 PST (History)
54 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alex Keybl [:akeybl] 2013-06-20 13:55:01 PDT
Plugin name: Flash
Plugin versions to block: -11.7.700.169
Applications, versions, and platforms affected: All Firefox versions (first time with CTP, given low user populations on 18-20)
Block severity: CTP

Reasons: Ensure that users on old Flash versions are protected from critical security bugs. For now we're using a criteria of versions of Flash released >3wk ago with a max of 20% of our overall population receiving the CTP experience.
Comment 1 Jorge Villalobos [:jorgev] 2013-06-20 14:41:32 PDT
*** Bug 885518 has been marked as a duplicate of this bug. ***
Comment 2 Robert Kaiser 2013-06-20 15:09:10 PDT
(In reply to Alex Keybl [:akeybl] from comment #0)
> Plugin name: Flash
> Plugin versions to block: -11.7.700.169
> Applications, versions, and platforms affected: All Firefox versions (first
> time with CTP, given low user populations on 18-20)

Well, only Mac and Windows, I believe. On Linux and Android, only older branches are available maintained. And on Windows, we might also not want to block the newest 10.3 release unless they stopped maintaining that branch.
Comment 3 Jorge Villalobos [:jorgev] 2013-06-20 15:12:31 PDT
The modified block has been staged: https://addons-dev.allizom.org/en-US/firefox/blocked/p178

It only covers the 11 branch on Windows and Mac.
Comment 4 Paul Silaghi, QA [:pauly] 2013-06-25 07:16:50 PDT
The blocklisting works fine on staging, details are here: https://wiki.mozilla.org/QA/Desktop_Firefox/Plugins/Blocklisting/Adobe_Flash#Adobe_Flash_11.7.700.169
Comment 5 Jorge Villalobos [:jorgev] 2013-06-25 10:19:36 PDT
Alex, given the release, what do you think is a good time to push this block and bug 837377?
Comment 6 Jorge Villalobos [:jorgev] 2013-06-28 09:58:24 PDT
The block has been updated in production.

https://addons.mozilla.org/firefox/blocked/p178
Comment 7 Paul Silaghi, QA [:pauly] 2013-07-01 05:51:30 PDT
The blocklisting works fine in production, details are here: https://wiki.mozilla.org/QA/Desktop_Firefox/Plugins/Blocklisting/Adobe_Flash#Adobe_Flash_11.7.700.169
Comment 8 Paul Silaghi, QA [:pauly] 2013-07-01 05:55:45 PDT
One question:
The latest blocklist seems to be downloaded in c:\Users\paul.silaghi\AppData\Roaming\Mozilla\Firefox\Profiles\r2mkrizt.default\blocklist.xml
What's up with "c:\Program Files (x86)\Mozilla Firefox 23b1\browser\blocklist.xml" ? It's different than the first one, and it seems to be out of date.
Comment 9 Jorge Villalobos [:jorgev] 2013-07-01 08:09:07 PDT
(In reply to Paul Silaghi [QA] from comment #8)
> What's up with "c:\Program Files (x86)\Mozilla Firefox
> 23b1\browser\blocklist.xml" ? It's different than the first one, and it
> seems to be out of date.

That's the one that ships with the installer, and it is used for the short time before the first blocklist is downloaded to the profile.
Comment 10 Paul Silaghi, QA [:pauly] 2013-07-01 08:20:08 PDT
Thanks for the info.
Comment 11 mohammed asharaf 2013-07-02 11:06:28 PDT
veryhappy to updated
Comment 12 zorro6 2013-10-04 19:10:09 PDT
Created attachment 813826 [details]
install_flashplayer11x32_mssd_aaa_aih.exe
Comment 13 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-10-10 14:25:16 PDT
Comment on attachment 813826 [details]
install_flashplayer11x32_mssd_aaa_aih.exe

Hiding this attachment as potentially malicious.

@zorro6 if you need help with a Flash or Click-to-Play related issue please consult support.mozilla.org. Please refrain from attaching .exe files to bugs in the future.

Thank you
Comment 14 m_azb17 2014-02-14 17:49:03 PST
yas ok thank youuuuuuuuuuuuuuuuuuu
Comment 15 wrrcee 2014-12-19 18:50:25 PST
Della vostra schifosissima lingua non me ne importa niente! Qui siamo in ITALIA e l'unica lingua parlata è l'ITALIANO! Se non lo conoscete imparatelo o usate il traduttore! Punto secondo: in Italia nessuno impone ad altri le sue decisioni, questo è un paese libero! Se voglio usare una vecchia versione del vostro programma e dei componenti aggiuntivi sono affari miei, sono Libera di decidere IO se rischiare o meno! Non esiste che prendiate voi le decisioni per me! Se non vi va bene voi e il vostro browser che ormai non vale più un cazzo, ritiratevi dal mercato italiano! Questo è un paese libero in cui di browser se ne trovano quanti si vuole migliori e con molte meno pretese.
FIREFOX HAI CHIUSO!!! PIU' TI AGGIORNI E PIU' FAI SCHIFO! E IN PIU' ORA IMPONI AGLI ALTRI DI AGGIORNARE
Comment 16 wrrcee 2014-12-19 18:58:46 PST
Della vostra schifosissima lingua non ci importa niente! Qui siamo in Italia e l’unica lingua parlata è l’italiano! Se non la conoscete imparatela o usate il traduttore! Punto secondo: in Italia nessuno impone agli altri le proprie decisioni, questo è un PAESE LIBERO! Perciò siamo LIBERI di decidere NOI cosa aggiornare. Se vogliamo tenerci una vecchia versione del vostro browser o dei componenti aggiuntivi è scelta nostra com’è scelta nostra ed esclusivamente NOSTRA se rischiare o meno, come dite voi. Non esiste che voi imponiate agli altri di aggiornare quello che volete voi! In Italia si usa così, se non vi va bene uscite dal mercato italiano. Tanto di browser se ne trovano quanti se ne vuole migliori e con meno pretese del vostro.
FIREFOX, HAI CHIUSO! PIU’ TI AGGIORNI PIU’ FAI SCHIFO ! VERGOGNA!
Comment 17 johpor 2014-12-20 13:17:35 PST
Why is Flash content still blocked when I am running version 15.0.0.239 of Shockwave Flash?  I am running version 34.0.5 of Firefox.
Comment 18 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2014-12-20 17:02:51 PST
(In reply to johpor from comment #17)
> Why is Flash content still blocked when I am running version 15.0.0.239 of
> Shockwave Flash?  I am running version 34.0.5 of Firefox.

Your version of Flash is blocked because of a 0-day exploit. You will need to download the latest version of Flash from adobe.com to get it working again.
 
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9163

In the future, I ask that you direct these types of questions on support.mozilla.org. Commenting on a year old bug report is strongly discouraged.
Comment 19 mar1ghl 2015-01-06 15:42:30 PST
Thank you
Comment 20 kingmackr 2015-07-01 18:49:46 PDT
i've read all the comments so far and i have tried everything people has suggested and nothing has worked. so all in all unblock flash players 15 to latest so people that don't have the bug or cant give 2 **** about the bug can still use flash player because i want to use it and Mozilla is not allowing me to its **** me off.
Comment 21 kingmackr 2015-07-01 18:53:19 PDT
plus updating flash doesn't seem to work ether which is also anoying
Comment 22 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2015-07-02 11:47:07 PDT
(In reply to kingmackr from comment #21)
> plus updating flash doesn't seem to work ether which is also anoying

This bug has been closed and is not a great place to comment if you're trying to get your issue resolved. There is an entire support team at https://support.mozilla.org/ who can help troubleshoot your issue and hopefully derive a solution.

Thank you

Note You need to log in before you can comment on or make changes to this bug.