Last Comment Bug 885551 - Enter PIN screen (and all text) is displayed in English for a device set to another locale
: Enter PIN screen (and all text) is displayed in English for a device set to a...
Status: VERIFIED FIXED
:
Product: Marketplace
Classification: Server Software
Component: Payments/Refunds (show other bugs)
: 1.0
: All All
: P1 normal (vote)
: 2013-07-11
Assigned To: Kumar McMillan [:kumar] (needinfo all the things)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-20 15:07 PDT by karina.filipe
Modified: 2013-07-11 09:39 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot (58.88 KB, image/png)
2013-06-21 10:29 PDT, karina.filipe
no flags Details
postfix-screenshot.png (52.81 KB, image/png)
2013-07-02 12:32 PDT, Kumar McMillan [:kumar] (needinfo all the things)
no flags Details
spanish-screenshot-fix.png (52.74 KB, image/png)
2013-07-03 13:05 PDT, Kumar McMillan [:kumar] (needinfo all the things)
no flags Details

Description karina.filipe 2013-06-20 15:07:44 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

1. Open marketplace
2. Search for a paid app
3. Click to buy
4. Start the process to create and account



Actual results:

The persona PIN screen is in English

(note: all of the PIN screens are in English, such as: wrong pin, confirmation pin, reset pin, forgot pin)


Expected results:

The interface during the PIN screens should be in Spanish
Comment 1 Wil Clouser [:clouserw] 2013-06-21 09:15:32 PDT
Please attach a screenshot.  I'm not sure what the persona PIN screen is.
Comment 2 karina.filipe 2013-06-21 10:29:10 PDT
Created attachment 765979 [details]
screenshot
Comment 3 Vikas Nanda 2013-06-21 12:35:36 PDT
Note that this issue also occurs for polish
Comment 4 Kumar McMillan [:kumar] (needinfo all the things) 2013-07-01 17:10:30 PDT
Spanish is working fine for me but I can confirm Polish translations are not working. I see that we have the localized strings so I am investigating further to see what could be happening
Comment 5 Wil Clouser [:clouserw] 2013-07-01 17:15:47 PDT
In addition to committing strings we also need .mo files.  I compiled them all and committed.  If that fixed it, yay, otherwise it's something else.
Comment 6 Kumar McMillan [:kumar] (needinfo all the things) 2013-07-02 12:32:20 PDT
Created attachment 770352 [details]
postfix-screenshot.png

Thank Wil, looks like the compile fixed it: https://github.com/mozilla/webpay/commit/4cf7ac215e827c79fcf0680546d8d469b9bcea5a

I'm attaching the fixed screen from dev using the Polish locale.
Comment 7 Victor Carciu 2013-07-03 08:10:36 PDT
This is still reproducible for Spanish on Stage : http://screencast.com/t/ocSFFziS5DSd
Comment 8 Kumar McMillan [:kumar] (needinfo all the things) 2013-07-03 13:05:04 PDT
Created attachment 770979 [details]
spanish-screenshot-fix.png

Can you post a video of reproducing the bug? When I start with a new flash, set the language to Spanish, open Marketplace Dev, set the region to Spain, log in, and begin a purchase I see Spanish localization. I attached a screenshot.
Comment 9 Kumar McMillan [:kumar] (needinfo all the things) 2013-07-03 13:12:32 PDT
sorry, nevermind. You said on MP Stage and I can confirm. investigating...
Comment 10 Kumar McMillan [:kumar] (needinfo all the things) 2013-07-03 13:33:51 PDT
spanish locales aren't working in prod either. Still searching for clues.
Comment 11 Kumar McMillan [:kumar] (needinfo all the things) 2013-07-03 16:01:43 PDT
Added some logging, still can't dig anything up. On Monday I'll try to inspect the headers closer.
Comment 12 Kumar McMillan [:kumar] (needinfo all the things) 2013-07-10 15:26:55 PDT
When I run this locally it works as expected but when run on production it returns 'en-us'

    >>> from webpay.base.middleware import LocaleMiddleware as LM
    >>> lm = LM()
    >>> lm.get_best_language('pl,en-us;q=0.7,en;q=0.3')
    'pl'

I'm digging in further...
Comment 13 Kumar McMillan [:kumar] (needinfo all the things) 2013-07-11 08:58:05 PDT
all locales were completely broken in stage/prod due to how funfactory requires us to whitelist locales for prod!

Fixed: https://github.com/mozilla/webpay/commit/2ed99c9c15e314be262fa0b757624adb16812800
Comment 14 Kumar McMillan [:kumar] (needinfo all the things) 2013-07-11 08:58:57 PDT
this fix is currently on stage, on prod soon
Comment 15 Victor Carciu 2013-07-11 09:39:38 PDT
Verified as fixed .
We still have some translations issues for Polish(bug 891935) but this is another issue.

Note You need to log in before you can comment on or make changes to this bug.