If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Assertion failure: cxArg, at dist/include/js/RootingAPI.h

RESOLVED FIXED

Status

()

Core
JavaScript Engine
--
critical
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gkw, Assigned: shu)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
x86_64
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fuzzblocker])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 765947 [details]
stack

ParallelArray(4277, (function() {}))

asserts a threadsafe js debug shell on m-c changeset 61c3c8b85563 with --ion-parallel-compile=on at Assertion failure: cxArg, at dist/include/js/RootingAPI.h
(Reporter)

Comment 1

4 years ago
autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   http://hg.mozilla.org/mozilla-central/rev/ce7085b63b2b
user:        Bobby Holley
date:        Thu Jun 20 11:05:34 2013 -0700
summary:     Bug 883450 - Assert that we're in a request whenever we create a Rooted<T>. r=terrence
Blocks: 883450
Flags: needinfo?(bobbyholley+bmo)
Hardly.
Flags: needinfo?(bobbyholley+bmo) → needinfo?(nmatsakis)
(Reporter)

Comment 3

4 years ago
Due to its simplicity, actually this is causing a lot of trouble (assorted crash signatures, etc.) in jsfunfuzz.
Whiteboard: [fuzzblocker]
It looks like the PJS code is passing null to the Rooted Constructor.
(Assignee)

Comment 5

4 years ago
This is more than a simple unrooting, in that right now we assume that there is a JSContext available for use inside ParallelArrayAnalysis for operations such as making new template objects while replacing MIR nodes.

I'm working on a patch to separate ParallelArrayAnalysis into 2 phases, one that might potentially need a JSContext, and one that doesn't.

If I can't get that patch done by tonight I'll post a temporary patch for this bug.
(Assignee)

Updated

4 years ago
Flags: needinfo?(nmatsakis)
(Assignee)

Updated

4 years ago
Depends on: 886632
(Assignee)

Updated

4 years ago
Depends on: 887002
(Assignee)

Comment 6

4 years ago
If fixes for bug 886632 and bug 887002 stick, this will be fixed.
(Assignee)

Updated

4 years ago
Assignee: general → shu
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.