Closed Bug 88583 Opened 19 years ago Closed 18 years ago

string bundle shouldn't be using using OpenInputStream(), block UI thread

Categories

(Core Graveyard :: History: Global, defect, P2, critical)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: le-mig_g, Assigned: bugzilla)

References

Details

(Keywords: perf)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010628
BuildID:    200162823 (0.9.2)

Moz freezes (and eat 100% of CPU time) when I try to acces the "(no host)"
(local documents) section of the history from the sidebar.

The history was generated by 0.9.1 just before my upgrade, and I could access it
with 0.9.1.

The most strange fact is that the "(no host)" section in the "Yesterday" part
does not cause any problem (but in "Today" it does).

There are no problem too with the history form the Task menu.
I'm not sure if this comne from the fact the document are local or not. I can
attach you a file in from my .mozilla directory if you want. I can't send you
talkback report because of the school firewall.

Reproducible: Sometimes
Steps to Reproduce:
Don't know exactly

Actual Results:  Moz freezes and leaks CPU (until I kill it)

Expected Results:  The history

XFree 4.0.3
Linux Debian "sid"
Kernel 2.4.1
Theme "Modern"
I'll take this and have a look
Assignee: matt → alecf
Component: Sidebar → History: Global
QA Contact: sujay → claudius
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash, stackneeded
nav triage team:

Adding hang keyword. Claudius, have you had time to look into reproducing this 
one? Gael, can you come up with a more consistent way of reproducing the hang?
Keywords: hang
nav triage team:

Marking nsbeta1+, p2, and mozilla1.0
Keywords: nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla1.0
nav triage team:

Looked at this again, leaving it where it is.
Blocks: 7251, 26482, 26606, 31804, 62177
Depends on: 76944
QA Contact: claudius → tao
Summary: sidebar history cause crash with local documents → string bundle shouldn't be using using OpenInputStream(), block UI thread
No longer blocks: 7251
Blocks: 7251
It can't make it happen again, sorry
argh.. take two at reassigning history bugs to new owner
Assignee: alecf → blakeross
QA Contact: tao → claudius
Target Milestone: mozilla1.0 → ---
Marking WFM per reporter.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.