Closed Bug 886125 Opened 9 years ago Closed 7 years ago

nme.com doesn't display correctly in Gaia browser

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: efrat, Assigned: karlcow, Mentored)

References

()

Details

(Whiteboard: [serversniff] [country-us] [sitewait] )

Attachments

(1 file)

57.92 KB, image/jpeg
Details
Attached image NME.jpg
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36

Steps to reproduce:

Browsed to "http://www.nme.com/" from Gaia browser

Tested on Firefox OS simulator
OS version 1.1.0.0-prerelease
Build Identifier 20130522133646

User Agent String is:
Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36


Actual results:

In the simulator - The site uploads as a desktop site and not mobile adjusted

On a device - The site uploads is not mobile optimized

Model: ZTE Open
OS version: 1.0.1.0-prerelease
Firmware: V1.01.00.01.019.117
Platform:18.0
Build identifier:20130528094315


Expected results:

The web page should have been displayed correctly for mobile 
Displays correctly on Firefox for Android and Chrome for Android
Confirmed, server side sniff:

mtaylor at omg-2 in ~
$ http --print=Hh GET http://www.nme.com User-Agent:"$FFOS"
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.nme.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Cache-Control: max-age=0, no-cache, no-store
Connection: keep-alive
Connection: Transfer-Encoding
Content-Encoding: gzip
Content-Type: text/html
Date: Tue, 17 Sep 2013 14:36:27 GMT
Expires: Tue, 17 Sep 2013 14:36:27 GMT
IgniteAkamaiMatch: 1
NmeAkamaiMatch: 1
Pragma: no-cache
Server: Apache
Set-Cookie: browsertype=web; expires=Wed, 18-Sep-2013 14:36:27 GMT; path=/; domain=.nme.com
Set-Cookie: ipc_geo=US; path=/; domain=.nme.com
Transfer-Encoding:  chunked
Vary: Accept-Encoding
X-IPC-BALANCEID: 03

mtaylor at omg-2 in ~
$ http --print=Hh GET http://www.nme.com User-Agent:"$FFA"
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.nme.com
User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Cache-Control: max-age=0, no-cache, no-store
Connection: keep-alive
Content-Encoding: gzip
Content-Length: 7775
Content-Type: text/html
Date: Tue, 17 Sep 2013 14:36:31 GMT
Expires: Tue, 17 Sep 2013 14:36:31 GMT
IgniteAkamaiMatch: 1
NmeAkamaiMatch: 1
Pragma: no-cache
Server: Apache
Set-Cookie: browsertype=palmtop; expires=Wed, 18-Sep-2013 14:36:31 GMT; path=/; domain=.nme.com
Set-Cookie: ipc_geo=US; path=/; domain=.nme.com
Vary: Accept-Encoding
X-IPC-BALANCEID: 03

Note they're setting a cookie "palmtop" vs "web", so you may have to clear that if you're spoofing on desktop.

letters@nme.com is listed as the email address for "Got Feedback?"
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [serversniff][country-us][contactready]
Contacted at the provided address.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Whiteboard: [serversniff][country-us][contactready] → [serversniff] [country-us] [sitewait]
Still the same issue and no answer since November.
Nickolas Stacey might be a better lead.
http://www.linkedin.com/in/nickolasstacey

Let's try.
http://twitter.com/MozWebCompat/status/451607570390605824
Whiteboard: [serversniff] [country-us] [sitewait] → [serversniff] [country-us] [sitewait] [mentor=kdubost]
Mentor: kdubost
Whiteboard: [serversniff] [country-us] [sitewait] [mentor=kdubost] → [serversniff] [country-us] [sitewait]
Trying another human contact.
http://twitter.com/MozWebCompat/status/534642625999929344
Difficult NME is a part of TimeInc which is a huge group.
This site looks like it fits the screen, but actually we only see the left column initially. Still, I'm nearly wondering if it's supposed to be that way..
Hallvord,
it is a common strategy on many desktop web site. The first column displays perfectly in the viewport. It's easy to get fooled specifically with screenshots if you can't compare with the real mobile site.

Maybe a solution to detect those would be to compare the width of the page in between iOS, Chrome and Firefox. and if the width has a more than a certain percentage discrepancy, you can flag it as dubious.
We get the right version of the site now. One remaining problem: typical Brighcove "Flash required" message instead of videos.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.