build error with gstreamer 0.10.35

RESOLVED DUPLICATE of bug 860978

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 860978
5 years ago
5 years ago

People

(Reporter: wolfiR, Unassigned)

Tracking

22 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
GStreamer support succeeds to build with 0.10.36 but not with 0.10.35:

[ 5095s] /home/abuild/rpmbuild/BUILD/mozilla/content/media/gstreamer/GStreamerReader.cpp: In member function 'virtual bool mozilla::GStreamerReader::DecodeVideoFrame(bool&, int64_t)':
[ 5095s] /home/abuild/rpmbuild/BUILD/mozilla/content/media/gstreamer/GStreamerReader.cpp:498:62: error: invalid conversion from 'int' to 'GstBufferCopyFlags' [-fpermissive]
[ 5095s] /usr/include/gstreamer-0.10/gst/gstbuffer.h:418:17: error:   initializing argument 3 of 'void gst_buffer_copy_metadata(GstBuffer*, const GstBuffer*, GstBufferCopyFlags)' [-fpermissive]

It's probably not worth to fix but wanted to file it anyway.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 860978
You need to log in before you can comment on or make changes to this bug.