Cannot build fennec since landing of bug 794282

VERIFIED INVALID

Status

()

VERIFIED INVALID
5 years ago
2 years ago

People

(Reporter: wgianopoulos, Assigned: eflores)

Tracking

({regression})

20 Branch
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Since landing of bug 874132 my android builds fail unless I specify "ac_add_options --disable-gstreamer" in my .mozconfig.  I should not have to do this.  The intent was to enable gstreamer for Linux builds not for android.
What makes you suspect that this has to do with bug 874132?
(Reporter)

Comment 2

5 years ago
Oops wrong bug.  Has to do with enabling gstreamer in Linux builds a completely different bug will fix in a second.

Meant bug 794282.
Blocks: 794282
No longer blocks: 874132
Summary: Cannot build since landing of bug 874132 → Cannot build fennec since landing of bug 794282
Assignee: nobody → edwin
I can't seem to reproduce this. Can you post your mozconfig?

After removing the gstreamer libs from my machine, desktop builds fail (predictably); but fennec builds still work fine.
Flags: needinfo?(wgianopoulos)
(Reporter)

Comment 4

5 years ago
OK so this is the same system I use to build my linux with gstreamer enable builds so just a different .mozconfig. The mozconfig lokis like this:

mk_add_options MOZ_MAKE_FLAGS=-j2

# Build Fennec
ac_add_options --enable-application=mobile/android

# Android
ac_add_options --target=arm-linux-androideabi
ac_add_options --with-endian=little
ac_add_options --with-android-ndk="$HOME/android-ndk-r8e"
ac_add_options --with-android-sdk="$HOME/android-sdk-linux/platforms/android-16"
ac_add_options --with-android-tools="$HOME/android-sdk-linux/tools"
ac_add_options --with-android-gnu-compiler-version=4.7
ac_add_options --with-android-version=9
ac_add_options --with-system-zlib

ac_add_options --with-java-bin-path=/opt/java/jdk1.6.0_29/bin
ac_add_options --disable-gstreamer
ac_add_options --disable-elfhack
ac_add_options --disable-tests

mk_add_options MOZ_OBJDIR=./fxand-obj
Flags: needinfo?(wgianopoulos)
(Reporter)

Comment 5

5 years ago
when it did not work the ac_add_options --disable-gstreamer was not there.
(Reporter)

Comment 6

5 years ago
OKprobablly an issue with my own setup had to do with conflicts between 32 and 64 bit libraries.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.