Closed Bug 886180 Opened 7 years ago Closed 6 years ago

Disable gstreamer in SeaMonkey

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set

Tracking

(seamonkey2.22 fixed)

VERIFIED FIXED
Tracking Status
seamonkey2.22 --- fixed

People

(Reporter: Callek, Assigned: Callek)

Details

Attachments

(3 files)

So we have the problem, where currently on SeaMonkey linux build machines we hit:

checking for gstreamer-0.10 >= 0.10.25
                      gstreamer-app-0.10
                      gstreamer-plugins-base-0.10... configure: error: gstreamer and gstreamer-plugins-base development packages are needed to build gstreamer backend. Install them or disable gstreamer support with --disable-gstreamer


The largest problem is that we don't have the ability to update to 0.10.25 on a RHEL5 machine from what I can tell.

The problem with that is gstreamer is disabled *by default* anyway, so expending too much effort to get this lib added is probably not worth it...
Attachment #766499 - Flags: review?(kairo)
Assignee: nobody → bugspam.Callek
Version: SeaMonkey 2.16 Branch → Trunk
Comment on attachment 766499 [details] [diff] [review]
[comm-central] fix mozconfigs to disable gstreamer

Review of attachment 766499 [details] [diff] [review]:
-----------------------------------------------------------------

Actually, I think I just read that Firefox is turning it on but preffing it off for now in 24 (currently trunk). But still, it's better to have us build and not support gstreamer for now than not build but support it.

I hope some kind of new builders with newer OS are in the plans, though. ;-)
Attachment #766499 - Flags: review?(kairo) → review+
https://hg.mozilla.org/comm-central/rev/9a6a19f66ed8
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Summary: Allow gstreamer to be default-disabled by SeaMonkey → Disable gstreamer in SeaMonkey
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #788467 - Flags: review?(bugspam.Callek)
Comment on attachment 788467 [details] [diff] [review]
Disable gstreamer on Linux64

Review of attachment 788467 [details] [diff] [review]:
-----------------------------------------------------------------

::: suite/config/mozconfigs/linux64/nightly
@@ +32,5 @@
>  #Use ccache
>  ac_add_options --with-ccache=/usr/bin/ccache
> +
> ++#Disable gstreamer building until we have libs that can support it
> ++# Bug XXXX <-- will update on checkin

update the bug number :-)
Attachment #788467 - Flags: review?(bugspam.Callek) → review+
Comment on attachment 788467 [details] [diff] [review]
Disable gstreamer on Linux64

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: cannot build linux64 on aurora
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: none
Attachment #788467 - Flags: approval-comm-aurora?
Attachment #788467 - Flags: approval-comm-aurora? → approval-comm-aurora+
Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23a1 ID:20130810003001 c-c:854f8af28f57 m-c:c5946a8bcd5b

Linux builds are appearing again for both for both i686 (interrupted 26-Jul) and x86_64 (interrupted 21-Apr, see bug 890594). Mac and win32 builds are also being made but I don't remember if and when building had been interrupted on those platforms. Unless there is some reason not to, I suppose this bug may be RESOLVED FIXED.
OS: Windows 7 → All
Hardware: x86_64 → All
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.