Closed Bug 886188 Opened 6 years ago Closed 4 years ago

Intermittent test_preload_actions.html | Test timed out.

Categories

(Core :: Audio/Video: Playback, defect, P5)

ARM
Android
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: philor, Assigned: jwwang)

References

Details

(Keywords: intermittent-failure)

Attachments

(3 files)

Blocks: 968602
No longer blocks: 968602
Duplicate of this bug: 968602
In test 12:

// 12. Change preload value from auto to metadata after load started,
// should still do full load, should not halt after metadata only.

I can't find such a statement in the spec: http://dev.w3.org/html5/spec-preview/media-elements.html.
In our current implementation, the later preload value will overwrite the previous one no matter whether load is started. In test 12, preload is changed to 'metadata' which tells the user agent just to download enough data to decode metadata. Therefore, 'canplaythrough' won't be fired since the user agent stops download after it has enough data to decode metadata and it results in timeout of the test.

Should we just remove the test 12 for the statement is not found in the spec?
Flags: needinfo?(roc)
(In reply to JW Wang[:jwwang] from comment #82)
> Should we just remove the test 12 for the statement is not found in the spec?

Yes, I think you're right!
Flags: needinfo?(roc)
1. remove test 12 since the spec is not found in the document: http://dev.w3.org/html5/spec-preview/media-elements.html.
2. add names to the tests for easier debugging
Assignee: nobody → jwwang
Status: NEW → ASSIGNED
Attachment #8392043 - Flags: review?(roc)
Blocks: 984259
Whiteboard: [le → [leave open]
1244 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | [started test15-29] Length of array should match number of running tests
1245 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | (14) Must get loadstart.
1246 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | (14) Must get loadedmetadata.
1247 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | (14) ReadyState must be >= HAVE_CURRENT_DATA
1248 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | (14) Got playback ended
1249 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | [finished test14-28] Length of array should match number of running tests
1250 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | [started test16-30] Length of array should match number of running tests
1251 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | (16) Got playback ended.
1252 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | [finished test16-30] Length of array should match number of running tests
1253 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | [started test17-31] Length of array should match number of running tests
1254 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | (17) Got playback ended.
1255 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | [finished test17-31] Length of array should match number of running tests
1256 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | [started test18-32] Length of array should match number of running tests
1257 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | (18) Got playback ended.
1258 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | [finished test18-32] Length of array should match number of running tests
1259 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | [started test19-33] Length of array should match number of running tests
1260 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | (19) preload is initially auto
1261 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | (19) no buffering has taken place
1262 INFO TEST-PASS | /tests/content/media/test/test_preload_actions.html | [finished test19-33] Length of array should match number of running tests

It looks like test15 is not finished and causes timeout. I will try to debug that.
(In reply to TBPL Robot from comment #92)
> philor
> https://tbpl.mozilla.org/php/getParsedLog.php?id=36467082&tree=Mozilla-
> Inbound
> b2g_emulator_vm mozilla-inbound opt test mochitest-3 on 2014-03-20 14:23:48
> revision: 284661ffd813
> slave: tst-linux64-spot-583
> 
> 1518 INFO TEST-UNEXPECTED-FAIL |
> /tests/content/media/test/test_preload_actions.html | Test timed out.
> 03-20 22:06:38.374   721   721 I GeckoDump: 1518 INFO TEST-UNEXPECTED-FAIL |
> /tests/content/media/test/test_preload_actions.html | Test timed out.

It looks like test16-13 is not finished.
(In reply to TBPL Robot from comment #95)
> philor
> https://tbpl.mozilla.org/php/getParsedLog.php?id=36538098&tree=B2g-Inbound
> Android 2.2 Tegra b2g-inbound opt test mochitest-3 on 2014-03-21 19:27:14
> revision: 9662636c45d8
> slave: tegra-212
> 
> 1268 INFO TEST-UNEXPECTED-FAIL |
> /tests/content/media/test/test_preload_actions.html | Test timed out.


Looks like test14-28 is not finished.
Summary: Intermittent Android test_preload_actions.html | Test timed out. → Intermittent test_preload_actions.html | Test timed out.
FYI, I'm planning to disable this on Android soonish.
try on mozilla-central: https://tbpl.mozilla.org/?tree=Try&rev=07ea12392fdc
No failure in test_preload_actions.html for 50 runs on each Android version.
Looks green enough to enable the test again.
Flags: needinfo?(ryanvm)
Sure, but do we know what fixed this? I guess the Timer patch?
Flags: needinfo?(ryanvm)
I guess so... since Android seemed to hit the bug more often than other platforms.
Depends on: 1033121
Per comment 247, it looks good enough to enable this test again on Android.
Attachment #8456592 - Flags: review?(cpearce)
Attachment #8456592 - Flags: review?(cpearce) → review+
Please check in 886188_enable_test_preload_actions_on_android.patch only, thanks.
Keywords: checkin-needed
No longer blocks: 984259
This is pretty frequent on Linux debug (32 and 64, with and without e10s). Any chance you can take another look at it, JW? :)
Flags: needinfo?(jwwang)
The test timed out in waiting for the 'canplaythrough' event. I wonder if bug 1093399 will fix it. Let's wait and see for a while.
Flags: needinfo?(jwwang)
Most recent timeouts fall in test15. Let's add some logs to debug test15 timeouts.
Attachment #8528114 - Flags: review?(cpearce)
Attachment #8528114 - Flags: review?(cpearce) → review+
Please check in 886188_add_debugging_logs.patch only, thanks.
Keywords: checkin-needed