[B2G][Settings] The "Unplug USB cable to disable" is truncated in the Storage settings section

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
RESOLVED WONTFIX
5 years ago
5 months ago

People

(Reporter: mdaniloff, Unassigned)

Tracking

({l12y})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v1.4 affected)

Details

(Whiteboard: LocRun1.2)

Attachments

(6 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 766783 [details]
usb storage overlap

When the user changes the language to Polski, The “Unplug USB cable to disable” text overlaps the “Enable USB cable to disable” enable/disable switch on the Settings Storage Header screen

Repro Steps: 
1. Updated to Leo Mozilla Build ID: 20130621070212
2. Connect the device to the pc via USB cable
3. From the Home screen, navigate to the Settings App
4. Enable the “Enable USB storage” switch under the Storage header
5. Disable the “Enable USB storage” switch under the Storage header

Actual Results:
The “Unplug USB cable to disable” text overlaps the enable/disable switch

Expected Results:
The complete text is displayed with sufficient spacing

Environmental Variables
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a34f6d62cb05
Gaia: cca61224e6df8e9f7e450d77cb6a8cf91029be64
Platform Version: 18.0

Notes: 
Repro frequency: 100%
See attached: screenshot

Updated

5 years ago
Blocks: 892075

Comment 1

5 years ago
Verified it's fixed on Leo V1.1. COM RIL, the text is no longer overlapped but the text is truncated now

Environmental  Variables:
Build ID: 20130801070210
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/aff662053ee8
Gaia: ddb922ed002e88d01f71199da32ff75911b455b2
Platform Version: 18.1
RIL Version: 01.01.00.019.180
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
It's worse now and I don't see how I could shorten this string.
Status: RESOLVED → REOPENED
Flags: needinfo?(firefoxos-ux-bugzilla)
Resolution: WORKSFORME → ---
Summary: [B2G][l10n][Settings-Notifications] Polski: The “Enable USB storage” switch is overlapped by text in the Storage settings menu → [B2G][l10n][Settings-Notifications] Polski: The „Unplug USB cable to disable” is turncated in the Storage settings section

Comment 3

5 years ago
Flagging Eric to advise (or reassign accordingly) on layout adjustments since text cannot be truncated.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(epang)
Created attachment 786301 [details]
20130806_155253_resized.jpg

It looks like the English version uses ellipses, could it be an option for this?  Francis, can I get your thoughts? I was thinking about a couple of options:

1. Increase the vertical space so there's space for another line of text while vertically centering the toggle.

2. Scroll the text in preset parameters.  The text would remain static then every few seconds scroll to reveal the remaining text.

Let me know if you need mock ups created or if you have any other thoughts.

Thanks!
Flags: needinfo?(epang) → needinfo?(fdjabri)
(In reply to Eric Pang [:epang] from comment #4)
> Created attachment 786301 [details]
> 20130806_155253_resized.jpg
> 
> It looks like the English version uses ellipses, could it be an option for
> this?  Francis, can I get your thoughts? I was thinking about a couple of
> options:
> 
> 1. Increase the vertical space so there's space for another line of text
> while vertically centering the toggle.
> 
> 2. Scroll the text in preset parameters.  The text would remain static then
> every few seconds scroll to reveal the remaining text.
> 
> Let me know if you need mock ups created or if you have any other thoughts.
> 
> Thanks!

I like the sound of option 1 better. Thanks!
Flags: needinfo?(fdjabri)

Comment 6

5 years ago
This issue also occurs in English.
 The "Unplug USB cable to disable" appears truncated in the Settings, when user toggles the "Enable USB storage" switch from on to off. (Screenshot is attached)

Asking for UX team input on this issue.
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 7

5 years ago
Created attachment 788388 [details]
Truncation in English
Created attachment 788892 [details]
Settings Subtext Spacing

Mock up of increased vertical space of list items when subtext needs more then one line.  Francis and Sergi, what do you think? If you both think this works, we should add this to the building blocks so bugs like this can be solved with the same fix in the future. Thanks!
Flags: needinfo?(sergiov)
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(fdjabri)

Comment 9

5 years ago
looks fine to me. 

Thanks Eric!
Flags: needinfo?(sergiov)
(In reply to Sergi from comment #9)
> looks fine to me. 
> 
> Thanks Eric!

Is this something we can add to the BB?
Flags: needinfo?(sergiov)

Updated

5 years ago
Depends on: 891296

Updated

5 years ago
Flags: needinfo?(fdjabri)

Updated

5 years ago
Flags: needinfo?(sergiov)

Comment 11

5 years ago
Polish text "Odłącz kabel USB, aby wyłączyć" is truncated in the Settings menu (under the Storage section) and in the Media Storage menu within Settings. In the Settings menu, the text displays as "Odłącz kabel USB, aby ...", while in the Media Storage menu it displays as "Odłącz kabel USB, aby wyłą...".

Settings menu: Truncation_Settings.jpg
Media Storage menu: Truncation_StorageManager.jpg

Environmental Variables:
Device: Buri v1.2 comRIL
BuildID: 20131024004000
Gaia: c57951d06f6c9fa5a762d151e4c75214b988679f
Gecko: ed279034d066
Version: 26.0a2
RIL version: 01.02.00.019.082
Blocks: 928174
Keywords: l12y
Whiteboard: LocRun1.2

Comment 12

5 years ago
Created attachment 821861 [details]
Truncation on settings menu.

Comment 13

5 years ago
Created attachment 821865 [details]
Truncation on Media Storage menu.

Comment 14

5 years ago
Created attachment 821875 [details]
Truncation on Media Storage menu.
Attachment #821865 - Attachment is obsolete: true
Duplicate of this bug: 860711
Still happening on 1.4. Any chance to fix this?
Summary: [B2G][l10n][Settings-Notifications] Polski: The „Unplug USB cable to disable” is turncated in the Storage settings section → [B2G][Settings] The "Unplug USB cable to disable" is truncated in the Storage settings section
This has been happening over and over from one version to another. I agree it would be nice to fix for 1.4
status-b2g-v1.4: --- → affected
Tried to look into this but I don't see any easy solutions.

The <small> element comes before the actual label in the markup, and it's using "position: absolute" to be displayed below it. That means that, if the element spans on multiple lines, the parent won't resize. 

Not sure that treating this element as an exception, inverting the markup and use "position: relative" makes sense, considering that all other elements (label, checkbox, icon) need to be adjusted.

Updated

4 years ago
QA Whiteboard: [COM=MTP/UMS]

Comment 19

5 months ago
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.