If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The user will not be given the option to enter their mobile number in order to obtain a MT SMS (wifi)

RESOLVED WORKSFORME

Status

Marketplace
Payments/Refunds
P1
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Vikas Nanda, Assigned: kumar)

Tracking

2013-07-04
Other
Gonk (Firefox OS)
Points:
---

Details

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 766876 [details]
log file.

steps to reproduce:

1. Start wifi
2. Open MP
3. Create a new account.
4. Search for a paid application. 
5. Click buy
6. Enter and confirm pin.


expected behavior:
The user should be given the option to enter their mobile number for authentication. 

observed behavior:

The user is not given the option to enter their mobile number to obtain a MT SMS.
(Reporter)

Comment 1

4 years ago
Created attachment 766877 [details]
screenshot
can you try this STR again after flashing your phone? What you describe is expected behavior if you are making a repeat purchase because Bango stores a cookie on the device to remember you by. If you flash your phone, it will clear the cookies.
when you say 'create a new account' - is that with a completely new email?
what marketplace server are you using?

Updated

4 years ago
Priority: -- → P1
This happens on dev and stage
Assignee: nobody → kumar.mcmillan
Target Milestone: --- → 2013-06-27
Created attachment 767472 [details]
logcat.txt

Here is a logcat. Please always include logcats because those have helpful JS logging.
hmm. I was able to reproduce it about twice but now I cannot reproduce it (dev or stage). Is this still happening for either of you?
(Reporter)

Comment 8

4 years ago
Kumar, I have flashed the device (1.0.1 - 26/06/13) and I am getting the same issue. I have tried it a few times today. 

I have uploaded a new logcat log.
(Reporter)

Comment 9

4 years ago
Created attachment 767793 [details]
log cat file

Updated

4 years ago
Component: General → Payments/Refunds
Vikas, can you go into Settings > Device Information > More Information > Developer, tick the box for Console Enabled, and re-upload a logcat? That will show the JS logging.
(Reporter)

Comment 11

4 years ago
Created attachment 767870 [details]
wifi purchase
(Reporter)

Comment 12

4 years ago
Kumar,

I have done what you have requested and uploaded a new log. Let me know if you need any more info
Target Milestone: 2013-06-27 → 2013-07-04
Vikas sent me a video showing login and purchase as the second user: https://people.mozilla.com/~kmcmillan/bug886511.mp4

This illustrates that although wifi is turned on, the cell data network is still active (Vikas also confirmed this on IRC). This means that Bango can still identity the device; it does not need to send an MT SMS. 

This is intended behavior. Switching to a new user like this does what is expected because carrier billing is tied to *device* not to user. We can address it better when we send a user ID to bango per bug 879949.

When testing this, I discovered bug 888036, something similar. It is more of an edge case though.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.