Closed Bug 88654 Opened 19 years ago Closed 18 years ago

RFE: ability to group websites to open at the same time

Categories

(SeaMonkey :: Location Bar, enhancement)

x86
Other
enhancement
Not set

Tracking

(Not tracked)

VERIFIED WONTFIX

People

(Reporter: AriB, Assigned: hewitt)

Details

I would like the ability to set up a group of websites from the URL bar that
will all launch at the same time. For example, I would type in
www.mozilla.org;www.mozillazine.org;www.mozdev.org 
and mozilla.org would load in the current window and 2 windows would open to
load the other websites.
Then I would define the group as a bookmark such as 'mozsites' giving me easy
access to all those websites at once without having to click on each one seperately.
Here's a way to get the same effect:
Make a bookmark for this url: (all in one line)
javascript:window.open('http://www.mozilla.org/','win1');window.open('http://www.mozillazine.org','win2');
window.open('http://www.mozdev.org','win3');window.close();
Add a keyword of mozsites using properties in bookmark manager.

Then type: mozsites    into the url bar, and all 3 sites come up in their own
window.

There's probably a cleaner way besides opening 3 windows and closing the
original one, but I figured I'd post it to show this line of thinking.
I hope there's a cleaner way because you lose the back history and also I would
like several websites as my home page at startup
ok here's javascript that seems to do the job. I want to load My Netscape and
mozillazine:
javascript:window.open("http://my.netscape.com","_content");window.open("http://www.mozillazine.org","_blank");
I put that as my home page and now I get those websites on startup
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Future
reassign url bar bugs to new owner..
Assignee: alecf → blakeross
Status: ASSIGNED → NEW
Target Milestone: Future → ---
Joe was dying to have these bugs. Who am I to say no?
Assignee: blakeross → hewitt
Interesting.... but the solutions offered via JS are a fine alternative.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → WONTFIX
mass-verifying WontFix bugs which haven't changed since 2001-12-31.

use the search string "BoletusEdulis" if you want to filter out this msg.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.