DND: when dragging link only, special "data format" should also be available in addition to general "text/html"

RESOLVED DUPLICATE of bug 41477

Status

()

Core
XUL
--
minor
RESOLVED DUPLICATE of bug 41477
17 years ago
17 years ago

People

(Reporter: Vlad Harchev, Assigned: blizzard)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla versions from 0.8 to 0.9.1 (others not checked) allow user to drag the link and drop it on other apps. In these versions of Mozilla, the list of data formats of this DND operation
is the same as list of data formats for plain "select any page fragment then drag and drop it" operation. It would be
much more beneficial to add yet another data format in case just the only link is being dragged - to allow drop targets (i.e. other apps) to distinguish just links from fragments of arbitrary html code.
In particular, netscape 4.x marked data with _NETSCAPE_URL format in the case of the only link being dragged - and that format is pertty supported by Gnome Midnight Commander (dropping such link to the desktop would create a shortcut, activating which that URL will load) and probably other file managers and programs.
I suggest providing data in the following additional formats:
_NETSCAPE_URL - just the link target
_MOZILLA_LINK - same as currently provided in "text/html" format (the point here is the name of format is different - that allows apps to distinguish fragments of html code from information about the link only.
And the data in other formats Mozilla currently provides dropped things.
--> blizzard
Assignee: trudelle → blizzard
The general idea of this is covered by Bug 41447 and one of it's duplicates Bug
74869.

*** This bug has been marked as a duplicate of 41447 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
<slapping self>.  I meant to mark this as a dupe of Bug 41477 - [RFE] Support
drag and drop of arbitrary content, inc. plugins.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Doing it right (hopefully) this time...

*** This bug has been marked as a duplicate of 41477 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
May God have mercy on us all. The 212 bug spam-o-rama is Now!
QA Contact: aegis → jrgm
You need to log in before you can comment on or make changes to this bug.