Closed Bug 886803 Opened 7 years ago Closed 7 years ago

Page (JIRA dashboard) not being rendered correctly

Categories

(Core :: JavaScript Engine, defect)

24 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla25
Tracking Status
firefox23 --- unaffected
firefox24 + verified
firefox25 + verified

People

(Reporter: paul.0000.black, Assigned: bhackett1024)

References

()

Details

(Keywords: regression)

Attachments

(3 files)

I've tried this on Linux 64-bit nightly only.

Go to https://jira.atlassian.com/secure/Dashboard.jspa

Some of the elements that should be on the page are not being shown.

This problem was not present in nightly of 21 June but is present in nightlies of 22 June onwards.

I've attached the 25 June nightly display (bad.png) and the 21 June nightly display (good.png).
Attached image Bad display
Attached image Good display
Error: ReferenceError: item is not defined
Source File: https://jira.atlassian.com/s/d41d8cd98f00b204e9800998ecf8427e/en_UK-pxiwuz-1988229788/6124/9/3cf5f1d86734f5d4a91123d17e43df71/_/download/contextbatch/js/atl.dashboard/batch.js
Line: 12


Last good: mozilla-inbound changeset 65f68cc061ec
First bad: mozilla-inbound changeset 16ddd7268abc
Bug 885522 - Move function heavyweight info to JSScript, r=luke.
Assignee: nobody → general
Blocks: 885522
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
OS: Linux → All
Product: Firefox → Core
Hardware: x86_64 → All
Version: 25 Branch → 24 Branch
Duplicate of this bug: 887297
Summary: Page not being rendered correctly → Page (JIRA dashboard) not being rendered correctly
Attached patch patchSplinter Review
new Function() would only populate the bindings on the resulting function script, not the bindings internal to the created function box (lame) which broke heavyweight tests when emitting bytecode for the function.  This patch changes things so that both bindings are populated.  The Bindings interface is rather complicated/awkward so this just does the same population twice.
Assignee: general → bhackett1024
Attachment #771771 - Flags: review?(jdemooij)
Attachment #771771 - Flags: review?(jdemooij) → review+
Comment on attachment 771771 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 885522
User impact if declined: broken webpages
Testing completed (on m-c, etc.): on m-i
Risk to taking this patch (and alternatives if risky): none
Attachment #771771 - Flags: approval-mozilla-aurora?
Attachment #771771 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Paul Black from comment #0)
> I've tried this on Linux 64-bit nightly only.
> 
> Go to https://jira.atlassian.com/secure/Dashboard.jspa
> 
> Some of the elements that should be on the page are not being shown.
> 
> This problem was not present in nightly of 21 June but is present in
> nightlies of 22 June onwards.
> 
> I've attached the 25 June nightly display (bad.png) and the 21 June nightly
> display (good.png).

Paul, this issue should be resolved now..Can you help us test the latest nightly or aurora and confirm the issue is fixed once the patch lands ? Thanks !
https://hg.mozilla.org/mozilla-central/rev/d5663e2b65b4
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Today's nightlies came off revision c0830a5933e8, which was prior to this landing. You can try a current tinderbox build or wait for tomorrow's nightly to confirm the fix.
Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20130710 Firefox/24.0
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20130710 Firefox/24.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20130710 Firefox/24.0

Verified as fixed on Firefox Aurora 24.0a2 buildid 20130710004004
Works for me on the nightly of 10 July.

Cheers.
Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20130710 Firefox/25.0
Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20130710 Firefox/25.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20130710 Firefox/25.0

Verified as fixed in Firefox Nightly 25.0a1 buildid 20130710030205
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.