Closed Bug 886939 Opened 8 years ago Closed 7 years ago

Download arrow animation is cut off by toolbar

Categories

(Firefox :: Theme, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: mstange, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:M9][Australis:P4])

Attachments

(1 file)

Attached image screenshot
The download arrow animation that appears when a download completes is cut off by the edges of the toolbar.

It looks like this was caused by bug 865926, which added this rule:

toolbar[overflowable] > .customization-target {
  overflow: hidden;
}
Whiteboard: [Australis:M?]
Whiteboard: [Australis:M?] → [Australis:M?][Australis:P4]
In order to keep this working, we'll probably have to do the animation outside of the toolbar. I'm not sure how tricky that will be though.

Mike, you've been looking at doing overlay things with highlighting findbar results. Do you think you could use that experience to look in to this?
Flags: needinfo?(mdeboer)
Sure, but the overlays were made easy in that case, because the <browser> is inside a <stack>. But that doesn't mean a similar approach can't be done in this case without a stack.
I can put this on my list to work on.
Flags: needinfo?(mdeboer)
Flags: needinfo?(mdeboer)
The vertical crop should disappear now that the fix for bug 876871 is checked in. However, a horizontal crop will remain if the button is at either end of the toolbar until we fix this properly. Mike, did you look at this already?
no, I wasn't able to do that. Only thing I could think of while investigating this is to reparent the 'downloads-indicator-notification' vbox to outside the toolbar and correct its position before animating. But that's not trivial.
Flags: needinfo?(mdeboer)
Depends on: 922847
This is fixed by bug 922847
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Whiteboard: [Australis:M?][Australis:P4] → [Australis:M9][Australis:P4][fixed-in-ux]
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M9][Australis:P4][fixed-in-ux] → [Australis:M9][Australis:P4]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.