If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

windows should not pop to the foreground when their content loads

RESOLVED DUPLICATE of bug 77675

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 77675
17 years ago
13 years ago

People

(Reporter: Zach Fine, Assigned: Matthew Paul Thomas)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.2) Gecko/20010629
BuildID:    2001062823

I often have several windows loading content in the background, and I don't like
it when they suddenly begin popping to the foreground in front of pages I'm
browsing or more annoyingly, forms I'm filling out. They ought to stay where
they are until I click on them to bring them to the foreground.

Reproducible: Always
Steps to Reproduce:
1.open a slowly loading page
2.open several other URLs, start browsing or filling out a form
3.oh no, the page in step 1 has jumped in front of the form you're filling out.
hope you remember whether you'd just typed in your password properly on that
form. Oh well I guess you can just click the form back to the foreground and
start over. Inconvenient though.

Actual Results:  My attention was diverted, and RSI began to set in.

Expected Results:  It should have let the slow page load in the background and
it should have left it there for me to bring to the foreground at a time of my
own  choosing.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 77675 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.