Closed Bug 887097 Opened 7 years ago Closed 7 years ago

Get rid of Gecko event sync time out

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 25
Tracking Status
firefox23 + fixed
firefox24 + verified
firefox25 --- fixed

People

(Reporter: jchen, Assigned: jchen)

References

Details

Attachments

(1 file)

Now that we have ANR reporting, we'd rather collect ANR reports than let Gecko event syncs time out, which causes crashes anyways.
I think it's still worthwhile to log long waits, but only every second.
Attachment #767568 - Flags: review?(bugmail.mozilla)
Comment on attachment 767568 [details] [diff] [review]
Get rid of Gecko event sync time out (v1)

Review of attachment 767568 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, thanks!
Attachment #767568 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/1f7776427454
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Blocks: 845867
Tracking nom since this may fix bug 863313 and friends
Since this might fix a reproducible topcrash we could go ahead with an uplift for tomorrow's beta and keep an eye on the crash stats to see if it has the intended effect. I'll approve the current patch for beta uplift based on this.
Comment on attachment 767568 [details] [diff] [review]
Get rid of Gecko event sync time out (v1)

[Triage Comment]

Will flag checkin needed.  We're taking this as a speculative fix for the crash in bug 863313 and will backout if necessary before ship if we don't see the results we're hoping for.
Attachment #767568 - Flags: approval-mozilla-beta+
Attachment #767568 - Flags: approval-mozilla-aurora+
Blocks: 834243
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.