Get rid of nsIFile main thread I/O in passwordmgr/storage-mozStorage.js

RESOLVED DUPLICATE of bug 853549

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 853549
5 years ago
5 years ago

People

(Reporter: Yoric, Unassigned)

Tracking

({main-thread-io})

Firefox Tracking Flags

(Not tracked)

Details

No longer blocks: 838889
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 853549
(Oops, midair, but maybe this is useful:)

How does this differ from bug 853549? Is this just about file.exists() calls?

The only such call here is in _removeOldSignonsFiles(). This function (and the whole legacy import thing) can go away (and I think an earlier patch in 853549 did so). It's migrating the pre- Firefox 3.0 format, and that's not really relevant now.

In the meantime, the impact here is limited since it's only run once (basically first time login manager is initialized in a new profile).
You need to log in before you can comment on or make changes to this bug.